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A script error occurs during lead qualification or leads cannot be qualified in Microsoft Dynamics CRM


Symptoms

After a Microsoft Dynamics CRM Online organization is upgraded to the December 2012 Service Update, but has not applied the latest Product Update, users may notice a script error that will occur during lead qualification. As a result of the script error, the lead is not qualified.

The same issue can also occur in Microsoft Dynamics CRM 2011 On Premise deployments with Update Rollup 12 applied.

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Cause

This problem can occur when the transactioncurrencyid ("Currency") or the companyname ("Company Name") fields are removed from the form prior to the December 2012 Service Update. Microsoft is aware of this symptom and will be addressing this issue in a future update. 

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Resolution

As a workaround, the transactioncurrencyid ("Currency") and/or companyname ("Company Name") field(s) can be added to the form. 

1. Click Settings, click Customizations, and then click Customize the System.

2. Under Components, expand Entities, and then expand Lead.

3. Click Forms.

4. Open the form(s) where the issue reproduces.

5. In the Field Explorer, locate and drag the "Currency" field onto the form. Repeat this action for the "Company Name" field if this is also missing from the form. 

6. Optional: To hide the fields on the form, double click on the field as it exists on the form, and under the Visibility section, uncheck "Visible by default", and click Ok. 

7. In the form editor, click Save, and then click Publish.


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More Information

Script Error Contents:

<CrmScriptErrorReport>
  <ReportVersion>1.0</ReportVersion>
  <ScriptErrorDetails>
   <Message>Unable to get value of the property 'id': object is null or undefined</Message>
   <Line>1</Line>
   <URL>/main.aspx?etc=4&extraqs=%3f_gridType%3d4%26etc%3d4%26id%3d%257b55AA7361-E463-E211-8A8B-78E3B5084B1B%257d%26pagemode%3diframe%26preloadcache%3d1358875549410%26rskey%3d199387296&pagetype=entityrecord</URL>
   <PageURL>/main.aspx?etc=4&extraqs=%3f_gridType%3d4%26etc%3d4%26id%3d%257b55AA7361-E463-E211-8A8B-78E3B5084B1B%257d%26pagemode%3diframe%26preloadcache%3d1358875549410%26rskey%3d199387296&pagetype=entityrecord</PageURL>
   <Function></Function>
   <CallStack>
   </CallStack>
  </ScriptErrorDetails>
  <ClientInformation>
   <BrowserUserAgent>Mozilla/5.0 (compatible; MSIE 9.0; Windows NT 6.1; WOW64; Trident/5.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E; InfoPath.3; MS-RTC EA 2)</BrowserUserAgent>
   <BrowserLanguage>en-us</BrowserLanguage>
   <SystemLanguage>en-us</SystemLanguage>
   <UserLanguage>en-us</UserLanguage>
   <ScreenResolution>1463x823</ScreenResolution>
   <ClientName>Web</ClientName>
   <ClientTime>2013-01-22T10:25:55</ClientTime>
  </ClientInformation>
  <ServerInformation>
    <OrgLanguage>1033</OrgLanguage>
    <OrgCulture>1033</OrgCulture>
    <UserLanguage>1033</UserLanguage>
    <UserCulture>1033</UserCulture>
    <OrgID>{}</OrgID>
    <UserID>{}</UserID>
    <CRMVersion>5.0.9690.3233</CRMVersion>
  </ServerInformation>
</CrmScriptErrorReport>

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Keywords: kbmbspartner, kbmbsmigrate, kbsurveynew, kb

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Article Info
Article ID : 2808214
Revision : 1
Created on : 1/7/2017
Published on : 1/24/2013
Exists online : False
Views : 74