Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

XADM: The Information Store Does Not Work After You Restore an Offline Backup of an Exchange Server 5.5 and Windows 2000 Cluster


View products that this article applies to.

This article was previously published under Q280770

↑ Back to the top


Symptoms

After you restore an offline backup of the information store database from a computer that is running Microsoft Windows NT 4.0 and Exchange Server 5.5 to a Microsoft Windows 2000 and Exchange Server 5.5 cluster, if you run the isinteg -patch command, it seems that the command completes successfully. However, when you start the information store, you may receive the following error message:
Microsoft Management Console
Windows could not start the Microsoft Exchange Information Store on local computer. For more information review the system event log. If this is a non-Microsoft service, contact the service vendor and refer to service specific error code 1012.
In addition, the following event ID message may be logged in the System log:
Event ID: 7024
Source: Service Control Manager
Description: The Microsoft Exchange Information Store service terminated with service specific error 1012.
The following event ID messages may be logged in the Application event log:
Event ID: 7202
Source: MSExchangeIS Private
Description: The database has been copied from the server (server name) to the server (server name). The database cannot function until Isinteg -patch has been run.
-and-
Event ID: 1005
Source: MSExchangeIS Private
Description: Unable to start the Microsoft Exchange Information Store. Error 0x3f4.
These messages indicate that the isinteg command actually has not completed successfully.

↑ Back to the top


Cause

This issue may occur if you omitted the trailing underscore when you set the required "_CLUSTER_NETWORK_NAME_" environment variable at a command prompt (for example, if you entered "_CLUSTER_NETWORK_NAME").

↑ Back to the top


Resolution

To resolve this issue, use the following format when you type the environment variable at a command prompt:
SET _CLUSTER_NETWORK_NAME_=Cluster Name
To determine the cluster name:
  1. Start the Cluster Administrator program from the Administrative Tools program group.
  2. Click to expand the Groups container, and then click the appropriate cluster group in the left pane.
  3. In the right pane, right-click the cluster name resource, click the Parameters tab, and then note the name that is listed on the tab.

    Use this name to set the cluster environment variable before you run isinteg -patch.

↑ Back to the top


More information

This article assumes that you performed an offline defragmentation procedure of the information store databases after the databases were restored and copied to the Windows 2000-based server before you ran isinteg -patch. When an Exchange Server 5.5 database is restored to another operating system or to the same operating system that is running a different service pack level, you must perform an offline defragmentation procedure of the database so that the corresponding service for that database can start.

For additional information, click the article number below to view the article in the Microsoft Knowledge Base:
224977� Information Store Fails to Start: 4294965882, FFFFFA7A, Event 177, 1081, and Others

↑ Back to the top


Keywords: KB280770, kbprb

↑ Back to the top

Article Info
Article ID : 280770
Revision : 5
Created on : 10/28/2006
Published on : 10/28/2006
Exists online : False
Views : 317