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Large print jobs time out after 60 seconds in Windows Server 2003 and in Windows 2000 Server


View products that this article applies to.

Symptoms

Large print jobs from some Line Printer Resource (LPR) clients may print as expected on a Microsoft Windows Server 2003-based or Windows 2000 Server-based computer that is running the Line Printer Daemon (LPD) service. Smaller print jobs may print correctly. You may be able to determine the maximum print job size that can be printed successfully in your client/server configuration. Other implementations of the LPR client software may not be affected.

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Cause

The Windows LPD server uses a time-out value to stop the LPD server from waiting indefinitely for hung or invalid print jobs. By default, this value is set to 60 seconds. Some LPR client implementations send the Receive Job command and then start creating a data file that is sent when it is ready. With a large print job, the delay can become long enough to invoke the time-out condition. When this condition occurs, the LPD server responds with a negative acknowledgement and cancels the job.

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Resolution

To resolve this problem, configure a larger time-out value by using Registry Editor. To do this, follow the steps in the "" section later in this article.

Note If you are using a Windows 2000 Server-based computer, you must first enable the required registry parameter before you can configure the time-out value. To do this, follow the directions in the "Windows 2000" section to install the hotfix for Windows 2000 Service Pack 1 (SP1) or to install the latest Windows 2000 service pack.

Windows 2000

Service pack information

To resolve this problem, obtain the latest service pack for Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
260910 How to Obtain the Latest Windows 2000 Service Pack
After you install the latest service pack for Windows 2000, a registry parameter is enabled so that you can configure the time-out value. To do this, follow the steps in the "" section later in this article.

Hotfix information for Windows 2000 Service Pack 1 and Service Pack 2

Note Only install this hotfix if you are running a Windows 2000 SP1-based or Windows 2000 SP2-based computer.

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Restart requirement


After you install this hotfix, you must restart your computer. If you manually install this hotfix, to restart the computer click OK on the hotfix message window or close the hotfix message window. To suppress the hotfix installation restart, specify the "-Z" parameter when you install the hotfix.

File information


The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   04-Jan-2001  22:33  5.0.2195.3106      21,776  Lpdsvc.dll    
WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
After you install this hotfix, a registry parameter is enabled so that you can configure the time-out value. To do this, follow the steps in the "" section later in this article.

Configure the time-out value

You can configure the following registry parameter for a Microsoft Windows Server 2003-based computer and for a Microsoft Windows 2000 Server SP3 or later-based computer.
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following key in the registry:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LPDSVC\Parameters
  3. On the Edit menu, click Add Value, and then add the following registry value:
    Value name: RecvTimeout
    Data type: REG_DWORD
    Data value: 1-1200 (seconds)
  4. Quit Registry Editor.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows 2000 Service Pack 3.

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More information

For additional information about Windows 2000 hotfixes and the '-Z' parameter, click the following article number to view the article in the Microsoft Knowledge Base:
262841 Command-line switches for Windows software update packages
For additional information about how to obtain a hotfix for Windows 2000 Datacenter Server, click the following article number to view the article in the Microsoft Knowledge Base:
265173 The Datacenter program and Windows 2000 Datacenter Server product
For additional information about how to install multiple hotfixes with only one reboot, click the following article number to view the article in the Microsoft Knowledge Base:
296861 How to install multiple Windows updates or hotfixes with only one reboot
For additional information about how to install Windows 2000 and Windows 2000 hotfixes at the same time, click the following article number to view the article in the Microsoft Knowledge Base:
249149 Installing Microsoft Windows 2000 and Windows 2000 hotfixes

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Keywords: kbautohotfix, kbhotfixserver, kbqfe, kbbug, kbfix, kbnetwork, kbwin2000presp3fix, kbwin2000sp3fix, KB280344

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Article Info
Article ID : 280344
Revision : 12
Created on : 1/29/2007
Published on : 1/29/2007
Exists online : False
Views : 591