Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Users are redirected back to a website's Single Sign On login page when using Windows Internet Explorer 9


Symptoms

Consider the following scenario. You are using Windows Internet Explorer 9 to browse to a web application that uses a Single Sign On (SSO) authentication scheme. When trying to log in to the website using the SSO web page, users are redirected back to the same SSO page to attempt logging in again. 


↑ Back to the top


Cause

This problem occurs in Internet Explorer 9 if the first HTTP 302 redirect response from the web server contains an Expires: 0 header value. This problem does not occur when using Internet Explorer 7, Internet Explorer 8, or Internet Explorer 10.


↑ Back to the top


Workaround

To work around this problem, choose one of the following options:

  1. Upgrade to Windows Internet Explorer 10 on the client machine.

    OR
  2. Modify the HTTP response headers being sent from the web server to use either Cache-Control: No cache or Cache-Control: max-age=0 instead of Expires: 0.

↑ Back to the top


More Information

Microsoft has confirmed that this is a problem in the products listed in the Applies-To section of this article. The behavior was introduced in Windows Internet Explorer 9 while trying to address a problem with infinite loops of recursive redirections that existed in previous versions of Internet Explorer.

↑ Back to the top


Keywords: kb

↑ Back to the top

Article Info
Article ID : 2800521
Revision : 1
Created on : 1/7/2017
Published on : 1/10/2013
Exists online : False
Views : 59