Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Time-out error when you run Setspn.exe in Windows 8 or Windows Server 2012


View products that this article applies to.

Symptoms

Assume that you run Setspn.exe and use the –X switch and the –F switch to identify duplicate Service Principal Names (SPNs) in Windows 8 or Windows Server 2012 in a domain forest. In this situation, you may encounter a time-out error. For example, you may receive an error message that resembles the following:
Checking forest DC=corp, DC=contoso, DC=com
Operation will be performed forestwide, it might take a while.
Ldap Error(0x55 -- Timeout): ldap_get_next_page_s <Date/Time>

The tool queries 100 objects in a paged query and is counting the pages on screen when you omit the -P option. When the problem does not happen always, you will notice that the problem will always occur on the last page.

Note This issue typically occurs when there are tens of thousands to hundreds of thousands of SPNs in the forest.

↑ Back to the top


Cause

This issue occurs because the SPN query times out after one minute.

The last page of the query is slow as the LDAP server needs to ensure there are no duplicate objects returned. Towards the end of the query most objects are suppressed as they were returned previously for other hits in the servicePrincipalName attribute.

↑ Back to the top


Resolution

Hotfix information


A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows 8 or Windows Server 2012.

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.
File information
The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 8 and Windows Server 2012 file information notes
Important Windows 8 hotfixes and Windows Server 2012 hotfixes are included in the same packages. However, only "Windows 8" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 8" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    VersionProductMilestoneService branch
    6.2.920 0.20 xxxWindows 8 and Windows Server 2012RTMLDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows 8 and Windows Server 2012" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 8
File nameFile versionFile sizeDateTimePlatform
Setspn.exe6.2.9200.2062324,57602-Feb-201307:04x86
For all supported x64-based versions of Windows 8 and of Windows Server 2012
File nameFile versionFile sizeDateTimePlatform
Setspn.exe6.2.9200.2062328,16002-Feb-201306:56x64

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More Information

The update sets the query time-out to three minutes. So with a default "MaxQueryDuration" LDAP Server Policy of two minutes, this policy will be in effect next to abort the query if it runs for an extended time. You may want to extend the server policy time-out when you are affected by the limit of two minutes.

Information about LDAP Server policies:

315071 How to view and set LDAP policy in Active Directory by using Ntdsutil.exe
http://support.microsoft.com/kb/315071/EN-US

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
Additional file information

Additional file information for Windows 8 and Windows Server 2012

Additional files for all supported x86-based versions of Windows 8
File nameX86_microsoft-windows-security-tools-setspn_31bf3856ad364e35_6.2.9200.20623_none_7d7a2d1fc878705a.manifest
File versionNot applicable
File size2,360
Date (UTC)02-Feb-2013
Time (UTC)08:36
PlatformNot applicable
Additional files for all supported x64-based versions of Windows 8 and of Windows Server 2012
File nameAmd64_microsoft-windows-security-tools-setspn_31bf3856ad364e35_6.2.9200.20623_none_d998c8a380d5e190.manifest
File versionNot applicable
File size2,364
Date (UTC)02-Feb-2013
Time (UTC)09:19
PlatformNot applicable

↑ Back to the top


Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertisebeginner

↑ Back to the top

Article Info
Article ID : 2799960
Revision : 1
Created on : 1/7/2017
Published on : 5/8/2013
Exists online : False
Views : 253