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Windows Server 2008 R2-based NDES server cannot submit a certificate request after you restart a server on which an enterprise CA is installed


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You install an enterprise certification authority (CA) on a server (server A) in a domain environment.
  • You configure the enterprise CA as a CA for a registration authority.
  • You restart server A.
  • You install the Network Device Enrollment Service (NDES) role service on another server (server B) that is running Windows Server 2008 R2.
  • You send a Simple Certificate Enrollment Protocol (SCEP) request by using a network device or SCEP simulator on server B.
  • Server B tries to submit a certificate request to the enterprise CA.
In this scenario, server B cannot submit the certificate request. Additionally, an event that resembles the following is logged on the NDES server:

Log Name: Application
Source: Microsoft-Windows-NetworkDeviceEnrollmentService
Date: <date time>
Event ID: 31
Task Category: None
Level: Error
Keywords: Classic
User: N/A
Computer: <computer name>
Description: The Network Device Enrollment Service cannot submit the certificate request (0x800706bf).
The remote procedure call failed and did not execute.

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Cause

This issue occurs because the Certcli.dll file maintains the cached state of the current DCOM connections to the CA. When you restart server A, the cached state of the connections is no longer valid.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2008 R2 Service Pack 1 (SP1).

For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    VersionProductMilestoneService branch
    6.1.760 1.22xxxWindows Server 2008 R2SP1LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are critical to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Certcli.dll6.1.7601.22215461,82411-Jan-201313:25x64
For all supported IA-64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Certcli.dll6.1.7601.22215881,66411-Jan-201312:25IA-64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2
File nameAmd64_microsoft-windows-c..tionauthorityclient_31bf3856ad364e35_6.1.7601.22215_none_362e39a06c63f08d.manifest
File versionNot applicable
File size34,147
Date (UTC)11-Jan-2013
Time (UTC)14:00
PlatformNot applicable
Additional files for all supported IA-64-based versions of Windows Server 2008 R2
File nameIa64_microsoft-windows-c..tionauthorityclient_31bf3856ad364e35_6.1.7601.22215_none_da114212b4048853.manifest
File versionNot applicable
File size34,145
Date (UTC)11-Jan-2013
Time (UTC)13:54
PlatformNot applicable

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Keywords: kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseadvanced, KB2799925

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Article Info
Article ID : 2799925
Revision : 1
Created on : 3/13/2013
Published on : 3/13/2013
Exists online : False
Views : 1606