Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

You cannot find the customer when you use the customer search to find a customer for a transaction in Microsoft Dynamics AX for Retail 2012 POS


View products that this article applies to.

This article applies to Microsoft Dynamics AX for Retail 2012 for all regions.

↑ Back to the top


Symptoms

Assume that you use the customer search to find a customer for a transaction in Microsoft Dynamics AX for Retail 2012 POS. However, you cannot find the customer. For example, you have a customer who is named as AAK. In Danish_norweigan_CI_AS, it is the same as ÅK. When the form sorts it in English, the letter does not exist.

↑ Back to the top


Cause

This problem occurs because the search result shows in grid is a copy of result and the original result is sorted by database according to the collation of the database.However, the grid always sorts the copy result automatically according to SQL_Latin1_General_CP1_CI_AS sorting rules without affecting original result. If collation sorting rules differs from the SQL_Latin1_General_CP1_CI_AS sorting rules, the copies of result are inconsistent. The selected item is fetched by mistake from the original result by index of the copy result.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. There is a "Hotfix download available" section at the top of this Knowledge Base article. If you are encountering an issue downloading, installing this hotfix, or have other technical support questions, contact your partner or, if enrolled in a support plan directly with Microsoft, you can contact technical support for Microsoft Dynamics and create a new support request. To do this, visit the following Microsoft website: You can also contact technical support for Microsoft Dynamics by phone using these links for country specific phone numbers. To do this, visit one of the following Microsoft websites:

PartnersCustomersIn special cases, charges that are ordinarily incurred for support calls may be canceled if a Technical Support Professional for Microsoft Dynamics and related products determines that a specific update will resolve your problem. The usual support costs will apply to any additional support questions and issues that do not qualify for the specific update in question.


↑ Back to the top


Installation information

If you have customizations for one or more of the methods or the tables that are affected by this hotfix, you must follow these steps:
  1. Review the changes that are documented in the .xpo file.
  2. Apply these changes in a test environment before you apply the hotfix in a production environment.


For more information about how to install this hotfix, click the following article number to view the article in the Microsoft Knowledge Base:
893082 How to install a Microsoft Dynamics AX hotfix

Prerequisites

You must have Microsoft Dynamics AX for Retail 2012 installed to apply this hotfix.

Restart requirement

You must restart the Application Object Server (AOS) service after you apply the hotfix.
File information
The global version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatformService branch
Aximpactanalysis.exeNot applicable60,28022-May-201220:19x86Not applicable
Axupdate.exeNot applicable60,26422-May-201220:19x86Not applicable
Clientoba32.mspNot applicable27,639,80828-Dec-201203:52Not applicableNot applicable
Clientoba64.mspNot applicable27,860,99228-Dec-201203:52Not applicableNot applicable
Components32.mspNot applicable24,518,65628-Dec-201203:52Not applicableNot applicable
Components64.mspNot applicable42,086,40028-Dec-201203:52Not applicableNot applicable
Helpserver64.mspNot applicable897,02428-Dec-201203:52Not applicableNot applicable
Objectserver32.mspNot applicable13,893,63228-Dec-201203:52Not applicableNot applicable
Objectserver64.mspNot applicable15,855,61628-Dec-201203:51Not applicableNot applicable
Retaildatabaseutility.mspNot applicable421,88828-Dec-201203:52Not applicableNot applicable
Retailheadquarters32.mspNot applicable802,81628-Dec-201203:52Not applicableNot applicable
Retailheadquarters64.mspNot applicable802,81628-Dec-201203:52Not applicableNot applicable
Retailpos.mspNot applicable3,506,17628-Dec-201203:52Not applicableNot applicable
Retailposplugins.mspNot applicable393,21628-Dec-201203:52Not applicableRETAILPOSP
Retailstoreconnect32.mspNot applicable446,46428-Dec-201203:52Not applicableNot applicable
Retailstoreconnect64.mspNot applicable446,46428-Dec-201203:52Not applicableNot applicable
Retailtransactionservice.mspNot applicable122,88028-Dec-201203:52Not applicableNot applicable
Setupsupport32.mspNot applicable12,009,47228-Dec-201203:51Not applicableNot applicable
Setupsupport64.mspNot applicable19,308,54428-Dec-201203:51Not applicableNot applicable
Traceparser.mspNot applicable434,17628-Dec-201203:52Not applicableNot applicable
Axsetupsp.exe6.0.1108.30801,390,78428-Nov-201215:54x86Not applicable
Axutillib.dll6.0.1108.806821,48006-Aug-201214:14x86Not applicable
Microsoft.dynamics.servicing.operations.dll6.0.888.43635,75222-May-201220:19x86Not applicable
Axsetupsp.resources.dll6.0.947.491382,84822-May-201220:19x86Not applicable
Axsetupsp.resources.dll6.0.947.491370,56022-May-201220:19x86Not applicable
Axsetupsp.resources.dll6.0.947.491374,65622-May-201220:19x86Not applicable
Axsetupsp.resources.dll6.0.947.491374,65622-May-201220:19x86Not applicable
Axsetupsp.resources.dll6.0.947.491370,56022-May-201220:19x86Not applicable
Axsetupsp.resources.dll6.0.947.491378,75222-May-201220:19x86Not applicable
Axsetupsp.resources.dll6.0.947.491370,56022-May-201220:19x86Not applicable
Axsetupsp.resources.dll6.0.947.491374,65622-May-201220:19x86Not applicable
Axsetupsp.resources.dll6.0.947.491370,56022-May-201220:19x86Not applicable
Axsetupsp.resources.dll6.0.947.491374,65622-May-201220:19x86Not applicable
Axsetupsp.resources.dll6.0.947.491370,56022-May-201220:19x86Not applicable
Axsetupsp.resources.dll6.0.947.491407,42422-May-201220:19x86Not applicable

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.

↑ Back to the top


Keywords: kbnoloc, kbsurveynew, kbexpertiseinter, kbexpertisebeginner, kbexpertiseadvanced, kbhotfixserver, kbmbsmigrate, kbmbspartner, kb, kbautohotfix, kbqfe, kbmbsquickpub

↑ Back to the top

Article Info
Article ID : 2798600
Revision : 3
Created on : 2/17/2017
Published on : 2/17/2017
Exists online : False
Views : 290