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XCON: Cannot Open Attachment for Inbound Message from ISOCOR Through SMTP


View products that this article applies to.

This article was previously published under Q279836

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Symptoms

If you receive a message with an attachment from ISOCOR by means of Simple Mail Transfer Protocol (SMTP), when you open the attachment, you may experience either of the following:
If you use a Post Office Protocol (POP), Internet Message Access Protocol (IMAP), or Outlook Web Access (OWA) client, there is no data (the attachment is empty). -or-

If you use a Microsoft Outlook Messaging Application Programming Interface (MAPI) client, you receive the following error message:
Operation failed

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Cause

This happens for SMTP messages that are formatted in the following manner:
Content-Type: multipart/mixed;
boundary="__boundary__12:12:2000_08:35:31_(15724)"
Content-Transfer-Encoding: 7bit

--__boundary__12:12:2000_08:35:31_(15724)
Content-Type: text/plain;
charset=iso-8859-2
Content-Transfer-Encoding: quoted-printable
this is my text

--__boundary__12:12:2000_08:35:31_(15724)
Content-Type: application/octet-stream;
name=test.doc
Content-Transfer-Encoding: base64
Content-Disposition: attachment;
filename=test.doc
binary is here

--__boundary__12:12:2000_08:35:31_(15724)
Content-Type: application/ms-tnef
Content-Transfer-Encoding: base64
Content-Disposition: attachment;
filename=WINMAIL.DAT
TNEF binary is here

--__boundary__12:12:2000_08:35:31_(15724)--

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Resolution

To resolve this problem, obtain the latest service pack for Microsoft Exchange 2000 Server. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
301378 XGEN: How to Obtain the Latest Exchange 2000 Server Service Pack
The English version of this fix should have the following file attributes or later:

Component: Information Store

File nameVersion
Store.exe6.0.4418.33

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Status

Microsoft has confirmed that this is a problem in Microsoft Exchange 2000 Server. This problem was first corrected in Microsoft Exchange 2000 Server Service Pack 1.

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More information

With the fix, you can get the real data of the attachment, and the incoming message will have two attachments: the attachment data itself, and a Winmail.dat file.

This is the same behavior as Microsoft Exchange Server 5.5, which is to receive two icons for the attachment. One icon contains the real data, and the second contains the formatting data in the Winmail.dat file. The message arrives with these two attachments because of the way the sender creates the Winmail.dat file. The message generated by ISOCOR contains a Winmail.dat with a missing property:
PR_ATTACH_TRANSPORT_NAME
Contact ISOCOR at the following Web site for any new updates on creating a properly formed Winmail.dat file:

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Keywords: KB279836, kbhotfixserver, kbqfe, kbfix, kberrmsg, kbbug

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Article Info
Article ID : 279836
Revision : 5
Created on : 2/21/2007
Published on : 2/21/2007
Exists online : False
Views : 277