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You cannot create a cluster file share on a third-party dynamic disk resource in Windows Server 2012


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You create a Windows Server 2012-based failover cluster and are using third-party dynamic disk resources. 
  • You configure a File Server service resource in the Failover Cluster Management snap-in.
  • You try to add a cluster file share in the File Server service resource.
In this scenario, the following issues occur:
  • You cannot create the cluster file share by using the Add File Share shortcut menu.

    Note If the Add File Share shortcut menu does not start, install the hotfix that is described in Microsoft Knowledge Base (KB) article 2795993 to resolve this issue.
  • When you try to create the cluster file share by using File Explorer, a Server Message Block (SMB) share is created instead of a cluster file share on the volume. For example, assume that you try to create a cluster file share that is named " ContosoShare" by using File Explorer on a drive named "ThirdPartyDisk" by using the following configuration:

    Cluster Name: ContosoCluster
    Cluster File server resource: \\ContosoFileShare
    Thirdparty storage resource that \\ContosoFileShare depends on: ThirdPartyDisk
    Server/Node Name: ContosoClusterNode1
    Share Name: ContosoShare

    In this situation, the file share is accessed through the "\\ContosoClusterNode1\ContosoShare" path instead of the "\\ContosoFileShare\ContosoShare" path.
  • You cannot create the cluster file share by using the NetShare API or a Windows PowerShell command. Additionally, you receive an error message that resembles the following:
    System error 87 – The parameter is incorrect

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Cause

This issue occurs because the Windows Server 2012-based failover cluster does not correctly determine the third-party dynamic disk to be a cluster disk.

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Resolution

Hotfix information

Examples of products that leverage third-party storage class resources which you should apply this hotfix if you are using these products include (but is not limited to):
  • Symantec Storage Foundation for Windows
  • Vision Solutions Double-Take Availability
  • SIOS DataKeeper Cluster Edition


To resolve these issues, install the hotfix that is described in this article. Additionally, install the hotfixes that are described in KB 2795993 and KB 2795997 to resolve all the related issues. For more information about KB 2795993 and KB 2795997, click the following article numbers to view the articles in the Microsoft Knowledge Base: 
2795993  New Share Wizard does not start when you try to create a cluster file share on a third-party dynamic disk resource in Windows 8 or Windows Server 2012
2795997  UI is displayed incorrectly when you right-click a third-party dynamic disk resource in the Available Storage area in Windows Server 2012

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2012.

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.
File information
The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.





Windows Server 2012 file information notes
Important Windows 8 hotfixes and Windows Server 2012 hotfixes are included in the same packages. However, only "Windows 8" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 8" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, milestone (RTM,SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:

    VersionProductMilestoneService branch
    6.2.920 0.20 xxxWindows Server 2012RTMLDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2012" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2012
File nameFile versionFile sizeDateTimePlatform
Clusapi.dll6.2.9200.16384372,22426-Jul-201203:05x64
Resutils.dll6.2.9200.16493626,68804-Jan-201309:30x64
Clusapi.dll6.2.9200.16384372,22426-Jul-201203:05x64
Resutils.dll6.2.9200.20598626,68804-Jan-201309:22x64


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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

Additional file information

Additional file information for Windows Server 2012

Additional files for all supported x64-based versions of Windows Server 2012
File nameAmd64_microsoft-windows-f..rcluster-clientcore_31bf3856ad364e35_6.2.9200.16493_none_ea056180c22cd1eb.manifest
File versionNot applicable
File size3,272
Date (UTC)04-Jan-2013
Time (UTC)23:50
PlatformNot applicable
File nameAmd64_microsoft-windows-f..rcluster-clientcore_31bf3856ad364e35_6.2.9200.20598_none_ea93ffbddb45f068.manifest
File versionNot applicable
File size3,272
Date (UTC)04-Jan-2013
Time (UTC)23:50
PlatformNot applicable

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Keywords: kberrmsg, kbexpertiseadvanced, kbsurveynew, kbautohotfix, kbhotfixserver, kbqfe, kb, kbfix

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Article Info
Article ID : 2796000
Revision : 3
Created on : 4/18/2018
Published on : 4/19/2018
Exists online : False
Views : 350