Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Problems printing from .NET 4.5 application to XPS-based printer.


View products that this article applies to.

Symptoms

When printing from a .NET Framework 4.5 application using an XPS-based print driver, you may experience the following issues:

1. If you make changes to the Printer settings, the default print setting values set in the Printer Property in Device and Printers are used instead.

2. If the user sets the Print Preview "on" as default in the Printer Properties, print execution always ends up with Preview open again and again (looping) unless the user cancels the print.

↑ Back to the top


Cause

Microsoft is aware of these issues and is working on a hotfix.

↑ Back to the top


Resolution

Once a hotfix is available to correct these problems, this article will be updated to point to the article associated with the hotfix release.

↑ Back to the top


Keywords: kb

↑ Back to the top

Article Info
Article ID : 2792405
Revision : 1
Created on : 1/7/2017
Published on : 12/7/2012
Exists online : False
Views : 536