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Troubleshooting errors in Business Portal For Microsoft Dynamics SL


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Symptoms

When you try to access Business Portal for Microsoft Dynamics SL or go to any of the Business Portal webpages you may receive an error message that resembles one of the following:


Server Error in '/' Application.
Runtime Error
Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

 

An Unexpected error has occurred.
Troubleshoot issues with Microsoft Sharepoint Foundation
Correlation ID: xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx

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Cause

There is a problem with Business Portal. However, the message that is received does not adequately describe the problem.

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Resolution

To receive a message that is more descriptive and that can help with troubleshooting, change the web.config file. To do this followed the steps:

1. On the server hosting the Business Portal website, browse out to the inetpub directory on the BP server 

2. Find the web.config file (typically in the C:\inetpub\wwwroot\wss\VirtualDirectories\80 folder) 

3. Make a backup copy of the web.config file 

4. Open the web.config file in Notepad

5. Locate the Callstack="False" value and change it to Callstack="True"

6. Locate the CustomErrors mode= "On" a value and change it to CustomErrors mode="Off"

7. Save the Web.config file

8. To enable the changes in the Web.config file, run the iisreset command. To do this, follow these steps:
a.  On the server on which Business Portal is installed, click Start, and then click Run. 
b.  Type the following command in the Open box,and then press ENTER:
iisreset

9. Access Business Portal or the webpage and note the message that is generated.

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Article Info
Article ID : 2788387
Revision : 2
Created on : 2/3/2017
Published on : 2/3/2017
Exists online : False
Views : 178