Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

PRB: Commerce Server Services Fail to Start When You Change Password for Startup Account


View products that this article applies to.

This article was previously published under Q278810

↑ Back to the top


Symptoms

Commerce Server services may fail to start after you change the password for the startup account that is specified for the service. Also, you may have to reset the identity account password for the Commerce Event Logging Com+ Application.

↑ Back to the top


Cause

After you change the password for the account, the services and the component still retain the previous password. Therefore, you cannot log on.

↑ Back to the top


Resolution

Change the password settings for the Commerce Server services and for the Commerce Event Logging Com+ Application. To change the password settings for the Commerce Server services, follow these steps:
  1. Click Start, point to Programs, click Administrative Tools, and then click Services.
  2. Double-click the Commerce Predictor service to open the service properties, and then click the Log On tab.
  3. Check the Log on as: setting to verify that it is set to use a specific account.
  4. Enter the correct password for the account specified, and then click OK.
  5. Repeat steps 2 through 4 for the Commerce List Manager and Commerce Direct Mailer services.
  6. Stop and then restart each service that you modified.
To change the password settings on the Commerce Event Logging Com+ Application:
  1. Click Start, point to Programs, click Administrative Tools, and then click Component Services.
  2. Click to expand Component Services, expand Computers, expand My Computer, and then expand Com+ Applications.
  3. Right-click the Commerce Event Logging application, and then click Properties.
  4. Type the correct password for the specified account, and then click OK.
NOTE: You may have to perform an IISRESET if you have previously loaded any Commerce Server Web sites or the Business Desk.

↑ Back to the top


More information

During the Commerce Server installation, the user who is currently logged on becomes the default account used for the Direct Mailer, Predictor, and List Manager service startup. Also, this account is the default account used for the identity of the Commerce Event Logging COM+ Application.

↑ Back to the top


Keywords: KB278810, kbprb, kbpending

↑ Back to the top

Article Info
Article ID : 278810
Revision : 4
Created on : 10/22/2003
Published on : 10/22/2003
Exists online : False
Views : 317