Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

MSCRMSandboxClient errors in the Event Viewer for Microsoft Dynamics CRM 2011


View products that this article applies to.

Symptoms

Within the Application Log of the Event Viewer on a Microsoft Dynamics CRM 2011 server, errors are being logged with the following details:

Log Name:      Application
Source:        MSCRMSandboxClient
Date:          MM/DD/YYYY HH:MM:SS
Event ID:      20242
Task Category: None
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      SERVER
Description:
The following information was included with the event:

w3wp.exe (90192)
net.tcp://localhost/CrmSandboxSdkListener-w3wp
System.ServiceModel.AddressAlreadyInUseException: The TransportManager failed to listen on the supplied URI using the NetTcpPortSharing service: the URI is already registered with the service.

↑ Back to the top


Cause

The services are experiencing an issue due to Loopback Check. Since the connection is using localhost and not the FQDN of the server it causes issues when registering the service. Loopback check is a security feature that is designed to help prevent reflection attacks on your computer.

↑ Back to the top


Resolution

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base: 322756 (http://support.microsoft.com/kb/322756/ ) How to back up and restore the registry in Windows

There are two methods to work around this issue, use one of the following methods, as appropriate for your situation.


Method 1: Specify host names (Preferred method if NTLM authentication is desired)To specify the host names that are mapped to the loopback address and can connect to Web sites on your computer, follow these steps:
  1. Click Start, click Run, type regedit, and then click OK.
  2. In Registry Editor, locate and then click the following registry key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\MSV1_0
  3. Right-click MSV1_0, point to New, and then click Multi-String Value.
  4. Type BackConnectionHostNames, and then press ENTER.
  5. Right-click BackConnectionHostNames, and then click Modify.
  6. In the Value data box, type the host name or the host names for the sites that are on the local computer, and then click OK. Separate each entry with a new line.
  7. Quit Registry Editor, and then restart the IISAdmin service.
Method 2: Disable the loopback check (less-recommended method) The second method is to disable the loopback check by setting the DisableLoopbackCheck registry key.

To set the DisableLoopbackCheck registry key, follow these steps:
  1. lick Start, click Run, type regedit, and then click OK.
  2. In Registry Editor, locate and then click the following registry key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa
  3. Right-click Lsa, point to New, and then click DWORD Value.
  4. Type DisableLoopbackCheck, and then press ENTER.
  5. Right-click DisableLoopbackCheck, and then click Modify.
  6. In the Value data box, type 1, and then click OK.
  7. Quit Registry Editor, and then restart your computer.

↑ Back to the top


Keywords: kbmbspartner, kbmbsmigrate, kbsurveynew, kb

↑ Back to the top

Article Info
Article ID : 2785590
Revision : 1
Created on : 1/7/2017
Published on : 12/14/2012
Exists online : False
Views : 213