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MPIO paths do not recover when you use MSDSM in Windows Server 2012


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You connect a logical disk through an Asymmetric Logical Unit Assignment (ALUA)-based storage area network (SAN) to a computer that is running Windows Server 2012.
  • You configure the disk as a multipath disk by using Microsoft Multipath I/O (MPIO) and Microsoft Device Specific Module (MSDSM).
  • You perform a path loss test (for example, you suddenly remove the cable or disconnect the controller).
In this scenario, some MPIO paths do not recover as expected. Therefore, you have to restart the server to restore the paths. Over time, this issue could lead to performance problems and possibly to a loss of all paths to one or more logical units.

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Cause

This issue occurs because the Host Bus Adapter (HBA) miniport driver or storage controller firmware for the device has an internal time-out value for Report Target Port Groups (RTPG) commands that is less than the default time-out value that MSDSM uses for RTPG commands. When an RTPG command is not completed in time, the miniport reports a time-out failure to MSDSM, and the path is not restored correctly. This issue is known to occur with Fibre Channel HBAs from multiple vendors and with SANs that support ALUA.

Note This hotfix increases the default time-out value that MSDSM uses for RTPG commands from 4 seconds to 10 seconds.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2012.

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

You have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.
File information
The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2012 file information notes
Important Windows 8 hotfixes and Windows Server 2012 hotfixes are included in the same packages. However, only "Windows 8" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 8" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies
  • The files that apply to a specific product, milestone (RTM,SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    VersionProductMilestoneService branch
    6.2.920 0.20 xxxWindows Server 2012RTMLDR
    6.2.920 0.16 xxxWindows Server 2012RTMGDR
  • GDR service branches contain only those fixes that are widely released to address widespread, critical issues. LDR service branches contain hotfixes in addition to widely released fixes.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2012" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2012
File nameFile versionFile sizeDateTimePlatform
Msdsm.sys6.2.9200.16463183,01622-Nov-201206:36x64
Msdsm.sys6.2.9200.20567183,01622-Nov-201206:30x64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Server 2012
Additional files for all supported x64-based versions of Windows Server 2012
File nameAmd64_msdsm.inf_31bf3856ad364e35_6.2.9200.16463_none_23258b8d65407362.manifest
File versionNot applicable
File size2,096
Date (UTC)22-Nov-2012
Time (UTC)06:40
PlatformNot applicable
File nameAmd64_msdsm.inf_31bf3856ad364e35_6.2.9200.20567_none_23b329807e5a7888.manifest
File versionNot applicable
File size2,096
Date (UTC)22-Nov-2012
Time (UTC)06:35
PlatformNot applicable
File namePackage_1_for_kb2784679_bf~31bf3856ad364e35~amd64~~6.2.1.0.mum
File versionNot applicable
File size2,023
Date (UTC)22-Nov-2012
Time (UTC)20:05
PlatformNot applicable
File namePackage_1_for_kb2784679~31bf3856ad364e35~amd64~~6.2.1.0.mum
File versionNot applicable
File size2,763
Date (UTC)22-Nov-2012
Time (UTC)20:05
PlatformNot applicable
File namePackage_for_kb2784679_rtm_bf~31bf3856ad364e35~amd64~~6.2.1.0.mum
File versionNot applicable
File size1,655
Date (UTC)22-Nov-2012
Time (UTC)20:05
PlatformNot applicable
File namePackage_for_kb2784679_rtm~31bf3856ad364e35~amd64~~6.2.1.0.mum
File versionNot applicable
File size1,678
Date (UTC)22-Nov-2012
Time (UTC)20:05
PlatformNot applicable
File nameUpdate-bf.mum
File versionNot applicable
File size1,778
Date (UTC)22-Nov-2012
Time (UTC)20:05
PlatformNot applicable

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Keywords: kb, kbautohotfix, kbfix, kbqfe, kbsurveynew, kbexpertiseadvanced, kbprb, kbhotfixserver

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Article Info
Article ID : 2784679
Revision : 1
Created on : 1/7/2017
Published on : 12/17/2012
Exists online : False
Views : 176