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"0x00000050" Stop error and an automatic restart on a Windows Server 2008 R2-based or Windows Server 2012-based computer


View products that this article applies to.

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Symptoms

On a computer that is running windows Server 2008 R2 or windows Server 2012, you receive a Stop error message that resembles the following, and the computer restarts automatically:
STOP: 0x00000050 (Parameter1, Parameter2, Parameter3, Parameter4)
Notes
  • This Stop error describes a PAGE_FAULT_IN_NONPAGED_AREA issue.
  • The parameters in this Stop error message vary, depending on the configuration of the computer.
  • Not all "Stop 0x00000050" errors are caused by this issue.

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Cause

The issue occurs because the allocation check logic fails when Win32k.sys receives a call to delete the surface. When this failure occurs, Win32k.sys tries to deallocate memory that was not allocated.

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Resolution

This hotfix is also available at Microsoft Update Catalog.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2008 R2, Windows Server 2008 R2 Service Pack 1 (SP1) or windows Server 2012.

For more information about how to obtain a Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To apply this hotfix, you do not have to change the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.
File information

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

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Keywords: kbmdd, kbautohotfix, kbfix, kbqfe, kbhotfixserver, kbsurveynew, kbexpertiseadvanced, kb

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Article Info
Article ID : 2781406
Revision : 1
Created on : 1/7/2017
Published on : 10/9/2014
Exists online : False
Views : 363