Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

System Message 10232 when logging into Microsoft Dynamics SL


View products that this article applies to.

Symptoms

When you try to log on to Microsoft Dynamics SL, you receive the following error messages.

System Message 10232

Assertion failure!

File: sqlapi.cpp

Line: 10364

Expression: tmpDidErrOccur == noError

Hit OK to stop program, and report the error to Microsoft Support, noting the failed expression, file name and line number.


Programming Bulletproof Error 10262

Invalid cursor value passed to sfetch1(). Please make sure cursor value is greater than 0. Also verify that this cursor has been passed to sql().Assertion Failed: abort=Quit, Retry=Debug, Ignore=Continue

↑ Back to the top


Cause

There are two System Databases that are both linked to the same Application Database.

↑ Back to the top


Resolution

  1. Open SQL Server Management Studio
  2. Execute the following select statement against each Microsoft Dynamics SL System Database:
    select databasename from domain
  3. If you find the same Microsoft Dynamics SL Application database name listed in more then one system database, it will cause the errors. Update or remove the duplicated record.
  4. Open Microsoft Dynamics SL Database Maintenance
  5. Connect to the server
  6. On the update databases tab, run the "Synchronize All Ownership and Security" process

↑ Back to the top


Keywords: kbmbsmigrate, kbmbspartner, kbsurveynew, kb

↑ Back to the top

Article Info
Article ID : 2780548
Revision : 2
Created on : 2/3/2017
Published on : 2/3/2017
Exists online : False
Views : 407