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AD RMS Client 1.0 (MSDRM) fails to open expired content


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Symptoms

When using a third-party file protector written for the Active Directory Rights Management Services (AD RMS) client 1.0, when configured with an explicit expiration date expired content fails to open. When a super user attempts to open encrypted expired data, DRMCreateLicenseStorageSession fails with return type E_DRM_INVALID_LICENSE.

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Cause

The AD RMS Client v1.0 (MSDRM) does not attempt to retrieve a use license from the AD RMS server for expired content.

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Resolution

This is resolved in the AD RMS Client v2.0 (http://www.microsoft.com/en-us/download/details.aspx?id=29892). This version of the client (MSIPC) communicates with the AD RMS server even in cases of expired content. 

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More Information

In a scenario where super users cannot open expired protected content with the AD RMS Client v1.0, a hotfix is available. Please contact Microsoft Technical Support to obtain this fix.

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Keywords: kb

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Article Info
Article ID : 2779826
Revision : 1
Created on : 1/7/2017
Published on : 11/19/2012
Exists online : False
Views : 268