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XCON: Unable to Read NDRs That Are Sent from a Japanese Server to an English Client


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This article was previously published under Q277856
IMPORTANT: This article contains information about editing the metabase. Before you edit the metabase, verify that you have a backup copy that you can restore if a problem occurs. For information about how to do this, see the "Configuration Backup/Restore" Help topic in Microsoft Management Console (MMC).

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Symptoms

When you are using an English-language Microsoft Outlook client that connects to a Japanese-language Exchange 2000 Server computer, when you receive an non-delivery report (NDR) from the Japanese-language server, the NDR is sent in Japanese. The English-language client cannot read the delivery status notification because the delivery status notification contains illegal characters.

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Cause

In Exchange Server versions 4.0, 5.0, and 5.5, and Exchange 2000, delivery status notifications are generated in the language of the Exchange Server computer. If a non-Japanese client connects to a Japanese server, or if delivery status notifications that are generated by a Japanese server are sent to a non-Japanese environment through the Internet, if you are using a non-Japanese client, when you receive the delivery status notification, you cannot read the notification because of the illegal characters.

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Workaround

WARNING: If you edit the metabase incorrectly, you can cause serious problems that may require you to reinstall any product that uses the metabase. Microsoft cannot guarantee that problems that result if you incorrectly edit the metabase can be solved. Edit the metabase at your own risk.

NOTE: Always back up the metabase before you edit it.

To work around this issue, configure the Japanese Exchange 2000 computer so that it generates delivery status notifications in English. To do so, edit the LanguageID entry of the Simple Mail Transport Protocol (SMTP) server instance in the metabase:
  1. Click Start, point to Programs, point to Administrative Tools, and then click Services.
  2. In the MMC Services dialog box, click SMTP service.
  3. On the Action menu, click Stop.
  4. At a command prompt, type the following text:
    cscript.exe c:\inetpub\adminscripts\adsutil.vbs set smtpsvc/smtpdsnlanguageid 1033
  5. Click Start, point to Programs, point to Administrative Tools, and then click Services.
  6. In the MMC Services dialog box, click SMTP service.
  7. On the Action menu, click Start.

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More information

The delivery status notification subject and the message header are encoded in UTF-7 and contain the JPN strings. The malformed NDR looks similar to the following text:
x-sender: SMTP: ""
x-receiver: SMTP: user1@domain.com
Received: from exchjpnsrv.domain.com ([10.1.1.1]) by exchjpnsrv.domain.com with Microsoft SMTPSVC(5.0.2195.2096);
Thu, 13 Dec 2000 16:10:37 -0700
From: postmaster@exchjpnsrv.domain.com
To: user1@domain.com
Date: Thu, 13 Jul 2000 19:01:12 -0700
MIME-Version: 1.0
Content-Type: multipart/report; report-type=delivery-status;
boundary="9B095B5ADSN=_01BFE6E4B90FA82A00000022exchjpnsrv"
Message-ID: 9wyM5dchw00000005@exchjpnsrv.domain.com
Subject: =?unicode-1-1-utf-7?Q?+kU1P4XK2YUuQGnfl- (+MKgw6TD8-)?=
Return-Path: ""
X-OriginalArrivalTime: 13 Dec 2000 16:10:37 (UTC)
FILETIME=[8DF7F570:01BFED1F]

This is a MIME-formatted message.
Portions of this message may be unreadable without a MIME-capable mail program.

--9B095B5ADSN=_01BFE6E4B90FA82A00000022domain.com
Content-Type: text/plain; charset=unicode-1-1-utf-7

+MFMwbpAad+Uwb4HqUtV2hDBrdR9iEDBVMIwwX5FNT+FytmFLkBp35TBnMFkwAg-

+ayEwblPXT+GABTB4MG6RTU/hMGtZMWVXMFcwfjBXMF8wAg-

nouser@domain.com

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Keywords: KB277856, kbprb, kberrmsg

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Article Info
Article ID : 277856
Revision : 5
Created on : 2/27/2007
Published on : 2/27/2007
Exists online : False
Views : 225