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"0x0000000A" Stop error on a Windows Server 2008 R2-based or Windows Server 2012-based Hyper-V server that has many pass-through disks


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have the Hyper-V role installed on a computer that is running Windows Server 2008 R2 or Windows Server 2012.
  • You have a virtual machine stored on the computer.
  • There are many pass-through disks assigned to the virtual machine.
  • Heavy I/O operations occur over the pass-through disks.
In this scenario, the system may crash. Additionally, you receive a stop error message that resembles the following:
Stop 0x0000000A (Parameter1, Parameter2, Parameter3, Parameter4)
Notes
  • This Stop error describes an IRQL_NOT_LESS_OR_EQUAL issue.
  • The parameters in this Stop error message vary, depending on the configuration of the computer.
  • Not all "0x0000000A" Stop errors are caused by this issue.

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Cause

This issue occurs because a stale thread object is dereferenced in memory.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2008 R2 Service Pack 1 (SP1) or Windows Server 2012.

For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    VersionProductMilestoneService branch
    6.1.760 1.22xxxWindows Server 2008 R2SP1LDR
  • GDR service branches contain only those fixes that are widely released to address widespread, critical issues. LDR service branches contain hotfixes in addition to widely released fixes.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are critical to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Passthruparser.sys6.1.7601.2224420,99207-Feb-201312:40x64
Storvsp.sys6.1.7601.22244120,32007-Feb-201312:40x64
Windows Server 2012 file information notes
Important Windows 8 and Windows Server 2012 hotfixes are included in the same packages. However, only "Windows 8" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 8" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, milestone (RTM,SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    VersionProductMilestoneService branch
    6.2.920 0.16 xxxWindows Server 2012RTMGDR
    6.2.920 0.20 xxxWindows Server 2012RTMLDR
  • GDR service branches contain only those fixes that are widely released to address widespread, extremely important issues. LDR service branches contain hotfixes in addition to widely released fixes.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2012" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows 8 and of Windows Server 2012
File nameFile versionFile sizeDateTimePlatform
Passthruparser.sys6.2.9200.1658520,99216-Apr-201323:13x64
Passthruparser.sys6.2.9200.2068920,99216-Apr-201323:12x64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2
File nameAmd64_wstorvsp.inf_31bf3856ad364e35_6.1.7601.22244_none_8ccecd18de4ad76a.manifest
File versionNot applicable
File size3,047
Date (UTC)08-Feb-2013
Time (UTC)13:31
PlatformNot applicable

Additional file information for Windows Server 2012

Additional files for all supported x64-based versions of Windows Server 2012
File nameAmd64_3c433ad1598387d02d2c17239bb3e4be_31bf3856ad364e35_6.2.9200.20689_none_0c954b92d7220df1.manifest
File versionNot Applicable
File size707
Date (UTC)17-Apr-2013
Time (UTC)15:37
PlatformNot Applicable
File nameAmd64_7cfe00b0d58e8aeb1b9b3b2a0aa41fc2_31bf3856ad364e35_6.2.9200.16585_none_b84893c2cad13a06.manifest
File versionNot Applicable
File size707
Date (UTC)17-Apr-2013
Time (UTC)15:37
PlatformNot Applicable
File nameAmd64_microsoft-hyper-v-passthru-parser_31bf3856ad364e35_6.2.9200.16585_none_7ab95248a7c7d448.manifest
File versionNot Applicable
File size2,720
Date (UTC)17-Apr-2013
Time (UTC)02:39
PlatformNot Applicable
File nameAmd64_microsoft-hyper-v-passthru-parser_31bf3856ad364e35_6.2.9200.20689_none_7b46f03bc0e1d96e.manifest
File versionNot Applicable
File size2,720
Date (UTC)17-Apr-2013
Time (UTC)01:36
PlatformNot Applicable
File nameUpdate-bf.mum
File versionNot Applicable
File size2,003
Date (UTC)17-Apr-2013
Time (UTC)15:37
PlatformNot Applicable
File nameUpdate.mum
File versionNot Applicable
File size2,036
Date (UTC)17-Apr-2013
Time (UTC)15:37
PlatformNot Applicable

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Keywords: kbexpertiseadvanced, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbautohotfix, KB2776366

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Article Info
Article ID : 2776366
Revision : 2
Created on : 6/13/2013
Published on : 6/13/2013
Exists online : False
Views : 457