Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

BUG: Campaign Ad URL Cannot Contain an Apostrophe


View products that this article applies to.

This article was previously published under Q277469

↑ Back to the top


Symptoms

In Commerce Server, if you create a new ad whose type is anything other than HTML or Non-Clickable Image for a customer, and the ad contains an apostrophe in the URL property, you may receive the following error message in the Ad_Display section:
"The control could not load. Please contact your system administrator."

↑ Back to the top


Cause

The Commerce Server Business Desk allows you to enter apostrophes in the URL field of the Campaign Manager Customer Properties. When a new ad is created for a customer, the image URL is automatically populated from the URL property of the customer for which the ad is created. The Advertisement Editor incorrectly handles the apostrophe, resulting in an error.

↑ Back to the top


Resolution

Remove the apostrophe from the URL property of the ad, and then recreate the ad.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in Commerce Server 2000.

↑ Back to the top


Keywords: KB277469, kbpending, kbbug

↑ Back to the top

Article Info
Article ID : 277469
Revision : 2
Created on : 10/18/2002
Published on : 10/18/2002
Exists online : False
Views : 345