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Error "Page Cannot Be Displayed" After You Delete Default Catalog Sets


View products that this article applies to.

This article was previously published under Q277353

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Symptoms

When users try to access a Commerce Server site, they may receive the following error message in their browser:

SiteName

The page cannot be displayed.

We apologize for the inconvenience. Please try again later. If the problem persists, please contact our webmaster.
where "SiteName" is the name of your Commerce site.

For a Retail2002 (Microsoft .NET) based site, you may receive the following error message:
Server Error in '/retail2002' Application.
----------------------------------------------------

The defaultAuthenticated catalogset ('Registered User Default CatalogSet') as specified in the CommerceServer\catalog\catalogSets section of web.config does not exist.

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: Microsoft.CommerceServer.Runtime.CommerceException: The defaultAuthenticated catalogset ('Registered User Default CatalogSet') as specified in the CommerceServer\catalog\catalogSets section of web.config does not exist.

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Cause

This error can occur when you delete the Anonymous User Default CatalogSet or the Registered User Default CatalogSet; as a result, there is no catalog set defined in the site.

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Resolution

To resolve this problem, follow these steps:
  1. Create two new catalog sets in the BizDesk, and name them accordingly for anonymous users and registered users.
  2. In the CatalogSet_Info table in the Commerce database in SQL, modify the CatalogSetID field for each catalog as follows:
    • Anonymous User Default CatalogSet: {11111111-1111-1111-1111-111111111111}
    • Registered User Default CatalogSet: {22222222-2222-2222-2222-222222222222}

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

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More information

By default, the retail site contains two catalog sets when it is unpacked: Anonymous User Default CatalogSet and Registered User Default CatalogSet. Commerce Server uses catalog sets to determine which catalogs should be available to a particular user. If these default sets are deleted, there is no catalog set for the user to see.

Steps to Reproduce Behavior

  1. In BizDesk, from the Catalog module, click Catalog sets and delete Anonymous User Default CatalogSet and Registered User Default CatalogSet.
  2. On the Start menu, click Run. At a command prompt, type the following command:
    IISRESET
  3. Try to browse to the site either as an anonymous user or as a registered user, and you receive the above-mentioned error message.

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Keywords: KB277353, kbprb, kbpending

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Article Info
Article ID : 277353
Revision : 4
Created on : 10/22/2003
Published on : 10/22/2003
Exists online : False
Views : 316