Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Error Message: The Product You Requested Is Not Currently Available Through This Catalog


View products that this article applies to.

This article was previously published under Q277316

↑ Back to the top


Symptoms

When you attempt to view a product through a browser in a Commerce Server 2000 online store, you may see the following informational message:
The product you requested is not currently available through this catalog.

↑ Back to the top


Cause

The product you are trying to view is a product based on a product definition that requires a product variant, but no product variants have been defined.

↑ Back to the top


Resolution

Either add a product variant to the product, or change the product definition to a definition that does not require a product variant.

↑ Back to the top


More information

A product definition can include product properties and product variant properties. For example, the "Book" product definition in the Retail site includes product properties and also product variant properties, while the "Generic Product" definition only includes product properties with no product variant properties.

If a product is created based on the "Book" product definition, and no variant product is created, the following message occurs when you attempt to view the item in the catalog:
The product you requested is not currently available through this catalog.
However, if the product is created with the "Generic Product" product definition, the item is viewable in the catalog.

↑ Back to the top


Keywords: KB277316, kbprb, kbpending

↑ Back to the top

Article Info
Article ID : 277316
Revision : 4
Created on : 10/22/2003
Published on : 10/22/2003
Exists online : False
Views : 440