Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

System may not start when creating a large number of logical units and volumes


View products that this article applies to.

Symptoms

If your system has a large number of logical unit numbers (LUNs) and volumes (over 700), when you restart Windows 2000 Server or Windows Server 2003, you may receive one of the following error messages:

Windows 2000 could not start because the following file is missing or corrupt:
\WINNT\SYSTEM32\CONFIG\SYSTEM.ced startup options for Windows 2000, Press F8.


You can attempt to repair this file by starting Windows 2000 Serveror Windows Server 2003 Setup using the original Setup floppy disk or CD-ROM. Select 'r' at the first screen to start repair.
Windows 2000 could not start because of an error in the software. Please report this problem as Loader Error 3.

You can attempt to repair this file by starting Windows 2000 Serveror Windows Server 2003 Setup using the original Setup floppy disk or CD-ROM. Select 'r' at the first screen to start repair.
You may receive one of these error messages if you reconfigured your system by deleting or removing existing LUNs and volumes, and then re-created or redetected the new LUNs and volumes.

↑ Back to the top


Cause

Windows 2000 server and Windows Server 2003 store information about LUNs and volumes that have been installed and configured in a computer in the SYSTEM hive of the registry. When a device (including a drive) is removed from a system, Windows 2000 Server and Windows Server 2003 retain the registry entries in case the device returns to the system; this is part of Plug and Play. This issue can occur after an array or set of drives is reconfigured, if they are detected as new devices and therefore create duplicate entries. If there are a large number of drives (over 700), this issue can cause the SYSTEM hive to grow large.

The SYSTEM hive is limited to approximately 10.3 megabytes (MB) in size in Windows 2000 Server. This is because the SYSTEM hive and the Windows kernel files must fit below 16 MB when Windows starts.

Because of design changes, Windows Server 2003 will usually not have this problem unless the /3GB switch is being used.

For more information about the SYSTEM hive and Windows Server 2003, click the following article number to view the article in the Microsoft Knowledge Base:

302594 The system hive memory limitation is improved in Windows Server 2003

↑ Back to the top


Resolution

To resolve this issue, use one of the following methods, depending on the state that the system is in. If this issue occurs after the fact (for example, if the computer does not start), contact Microsoft Product Support Services for assistance in repairing your SYSTEM hive and restoring your Windows installation to a bootable state.

For a complete list of Microsoft Product Support Services phone numbers and information on support costs, visit the following Microsoft Web site:

How to repair a computer that you cannot restart

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows
If you already tried to restart the computer and you received the error message that is described in the "Symptoms" section of this article, follow these steps:

  1. Install a parallel installation of Windows 2000 Server or Windows Server 2003 on the system.


    For more information about how to perform a parallel installation, click the following article number to view the article in the Microsoft Knowledge Base:

    266465 How to perform a parallel installation of Windows 2000 or Windows Server 2003

    NOTE: For the purposes of this article, assume that the original installation is in C:\Winnt and the new parallel installation is Winnt.new.


    Note The original installation folder for Windows 2003 Server is in C:\Windows.
  2. After you complete the parallel installation, log on to the computer in the parallel installation as the local administrator.
  3. Start Regedt32.
  4. Click the HKEY_LOCAL_MACHINE on Local Machine window to bring it to the front.

  5. Click the root folder HKEY_LOCAL_MACHINE.
  6. On Windows 2000 Server, on the Registry menu, click Load Hive. On Windows Server 2003, on the File menu, click Load Hive
  7. Locate the SYSTEM hive by browsing to the C:\Winnt\System32\Config folder, and then back up the System file.


    NOTE: Verify that you are backing up the System file and not the System.log file.
  8. Click the System file, and then click Open.
  9. In the Key Name box, type
    OriginalInstall, and then click OK.


    NOTE: The name that you choose is not important, as long as it is unique to the subhive that is displayed.
  10. The loaded subhive named OriginalInstall is now listed. Expand the
    OriginalInstall branch.
  11. Click the Select key.
  12. Note the settings for the Current, Default,
    Failed, and LastKnownGood registry values.


    The numbers in these registry values correspond to the numbers of the CONTROLSET keys that are also listed under the Select key. Under normal circumstances, the CONTROLSET001 key and the
    CONTROLSET002 key are listed.


    The settings for the Current and Default values is normally 0x1, and the corresponding CONTROLSET key for these values is CONTROLSET001. The setting for the LastKnownGood
    value is normally 0x2, and the corresponding CONTROLSET key is
    CONTROLSET002. The setting for the Failed value is normally 0, and no corresponding CONTROLSET key exists. However, if a damaged CONTROLSET exists, the setting for the Failed value may be 0x3, and the corresponding CONTROLSET key may be
    CONTROLSET003.


    For more information about how to use the Select key and ControlSets, click the following article number to view the article in the Microsoft Knowledge Base:

    102984 REG: ControlSet\Select subkey entries

  13. Click the CONTROLSET key that corresponds to the setting of the
    Failed value that you noted in step 12.
  14. On Windows 2000 Server, on the Security menu, click Permissions. On Windows Server 2003, on the Edit menu, click Permissions
  15. On Windows 2000 Server, select to clear the Allow inheritable permissions from parent to propagate to this object check box. On Windows Server 2003, click the Advanced button, and then select to clear the Allow inheritable permissions from parent to propagate to this object and all child objects. Include these with entries explicitly defined here check box.
  16. In the dialog box, click Remove.
  17. Remove the users and groups that are listed.
  18. Add the local administrator, and make sure that the account has Full Control permissions.
  19. Click Advanced.
  20. Click to select the Reset Permissions on all child objects and enable propagation in inheritable permissions check box, and then click OK.
  21. In the Security dialog box, click Yes.
  22. In the Permissions dialog box, click OK.
  23. Delete the CONTROLSET that corresponds to the Failed set.


    NOTE: The preceding steps are required to remove security on the hive, so that you can delete it. Note that you have backed up the SYSTEM hive.
  24. Repeat steps 13 through 23 to delete the CONTROLSET that corresponds to the LastKnownGood value.
  25. Double-click the CONTROLSET that corresponds to the Current value.
  26. Double-click ENUM.
  27. Click the SCSI key.
  28. Use steps 14 through 23 to set the proper permissions, and then delete the SCSI key.


    NOTE: The SCSI key is rebuilt during the next start.
  29. Click the STORAGE key.
  30. Use steps 14 through 23 to set the proper permissions, and then delete the STORAGE key.


    NOTE: The STORAGE key is rebuilt during the next start.
  31. Under HKEY_LOCAL_MACHINE, click OriginalInstall.
  32. On Windows 2000 Server, on the Registry menu, click Save Key, and then save the file to the desktop as System with no extension. On Windows Server 2003, on the File menu, click Export, and in the Save as type drop down, choose Registry Hive Files (*.*). Then save the file to the desktop with the file name System with no extension..

    NOTE: Saving the file removes any white space in the hive and reduces the size of the file.
  33. Make sure that OriginalInstall is still selected.
  34. On the Registry menu, click Unload Hive, and then click Yes for confirmation.
  35. Quit Regedt32.
  36. Use My Computer to browse to the C:\Winnt\System32\Config folder, and then rename the existing System file to System.org.
  37. Copy the System file from the desktop to C:\Winnt\System32\Config.
  38. Restart the computer and choose the original installation.

↑ Back to the top


More Information

If you want to be proactive because you believe that your server is at risk, use the following procedure to remove the registry entries for drives that have been physically removed.

The following instructions describe how to incorporate the Scrubber utility in a Windows 2000 environment by creating a shutdown script that checks the size of the SYSTEM hive. If the SYSTEM hive is over 8 megabytes (MB), the Scrubber utility deletes the removed drives and attempts to clean up the Dynamic disk database and compress any white space. The script does not remove any drives from the Dynamic disk database that were part of any type of RAID volume, including spanned volumes and striped volumes.

In addition, read the Readme.txt file that is contained in the utility package for a description of all of the files in the package.

↑ Back to the top


To create a shutdown script that checks the size of the SYSTEM hive, follow these steps:
  1. Download the package and extract the contents to the SYSTEM partition in a folder named C:\Scrubber.
  2. Click Start, and then click Run.
  3. Type MMC, and then click OK.
  4. On the Console menu, click Add/Remove Snap-in.
  5. Click Add.
  6. Click Group Policy in the snap-in list, and then click Add.
  7. The Group Policy object defaults to "Local Computer;" click Finish.
  8. Click Close, and then click OK.
  9. Click the plus sign (+) in the left pane to expand the Local Computer Policy branch, and then expand the Windows Settings branch.
  10. In the right pane, double-click the Shutdown policy
  11. Click Add, and then click Browse.
  12. Locate the C:\Scrubber folder, click the Cleanup.vbs file, and then click OK.
  13. Click OK until you close the Shutdown Policy and close the MMC snap-in. You do not need to save the console settings for the script to run.
  14. In Control Panel, double-click the System icon.
  15. Click the Advanced tab, and then click Environment Variables.
  16. Under System Variables, click the Path variable, and then click Edit.
  17. Append the following text to the end of the variable:
    ;C:\SCRUBBER
  18. Click OK for variables, and then click OK in System Properties.
With the shutdown script in place (Cleanup.vbs), if several drives fail and they are Dynamic disks, they are displayed in Disk Management as FAILED. You may need to right-click Disk Management, and then click Rescan Disks if the host bus adapter (HBA) does not use Plug and Play events if the drives are not reported immediately as FAILED.


For more information about similar issues, click the following article numbers to view the articles in the Microsoft Knowledge Base:

216369 Unable to create a large number of Dynamic Host Configuration Protocol (DHCP) scopes

244135 Too many printers can cause unsuccessful boot

259930 Cannot start Windows 2000 with a large number of DNS zones

269075 Error message: "Windows could not start because the following file is missing or corrupt: \Winnt\System32\Config\Systemced"

270028 Windows NT may not start with many DFS shares

Windows Server 2003 increases the memory that is available at boot time so that the size of the System hive is not as relevant.

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

302594 The system hive memory limitation is improved in Windows Server 2003

If you are using the /3GB switch in Windows Server 2003, the 16-MB limit still applies until Windows Server 2003 Service Pack 1 (SP1) is available. Microsoft recommends that you create a second entry in the Boot.ini file that does not have the /3GB switch so that more memory is available.

↑ Back to the top


Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Windows Server 2003 hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

There are no prerequisites for installing this hotfix.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003, Itanium-based versions
File nameFile versionFile sizeDateTimePlatform
Scrubber.exe5.2.3790.249623,04028-Jul-200505:16IA-64
Windows Server 2003, x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirement
Scrubber.exe5.2.3790.249612,80028-Jul-200505:16x64SP1
Windows Server 2003, x86-based versions
File nameFile versionFile sizeDateTimePlatformSP requirement
Scrubber.exe5.2.3790.249610,24027-Jul-200500:45x86SP1

↑ Back to the top


Windows 2000 hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

There are no prerequisites for installing this hotfix.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Scrubber.exe5.2.3790.23810,24012-Aug-200500:29x86

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Server 2003 Service Pack 2.

↑ Back to the top


Keywords: kbbillprodsweep, kbwin2000fixnosp, kbprb, kbpending, kbhardware, kberrmsg, kbenv, kbqfe, kbwinserv2003sp2fix, kbpubtypekc, kbfix, kbbug, kbwin2000presp5fix, kb, kbpubtypepublic, kbautohotfix, kbhotfixserver

↑ Back to the top

Article Info
Article ID : 277222
Revision : 3
Created on : 4/18/2018
Published on : 4/19/2018
Exists online : False
Views : 724