Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

"Sorry, we could not open 'File Name'" error message when you try to update a link in an Excel workbook from a OneDrive (formerly SkyDrive) client application


View products that this article applies to.

Symptoms

Consider this scenario:
  • You install a Microsoft OneDrive (formerly SkyDrive) client application on a computer that has�Microsoft Excel 2013 installed.
  • You log on to the OneDrive (formerly SkyDrive) client application.
  • You move an Excel workbook (.xlsx file) from the local disk to the local OneDrive (formerly SkyDrive) folder.
  • The workbook contains links to another workbook that is stored on the local disk.�
  • You open the workbook from the OneDrive (formerly SkyDrive) client application.
  • You try to update the links in the workbook.

In this scenario, you cannot update the links in the workbook. Additionally, you receive the following error message:
Sorry, we could not open File Name.

When you click OK, you receive the following error message:
Microsoft Excel cannot access the file File Name. There are several possible reasons:
The file name or path does not exist.
The file is being used by another program.
The workbook you are trying to save has the same name as a currently open workbook.

Note The File Name�in the error message is�the HTTP path�of the source file that the�link references.

↑ Back to the top


Cause

This issue occurs because the links are changed to point to OneDrive (formerly SkyDrive) locations. This occurs when you move the workbook to the OneDrive (formerly SkyDrive) folder.�

↑ Back to the top


Workaround

To work around this issue, follow these steps:
  1. Move the workbook back to the original location.
  2. Open the workbook in Excel 2013, and make sure that the links are correct.�
  3. Click Save As under the FILE tab, and then save the workbook to a OneDrive (formerly SkyDrive) location.

↑ Back to the top


Keywords: KB2769342, kbprb, kbexpertiseinter, kbinfo, kbsurveynew

↑ Back to the top

Article Info
Article ID : 2769342
Revision : 2
Created on : 2/19/2014
Published on : 2/19/2014
Exists online : False
Views : 468