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Your user name and password are rejected when you try to start WinRE in Windows 8 or in Windows RT


View products that this article applies to.

Symptoms

Assume that you start Windows Recovery Environment (WinRE) from the Boot Options menu on a computer that is running a multilanguage version of Windows 8 or of Windows RT. You type your user name and password when you are prompted to do this. However, the operation fails, and you receive an error message that states that the password is incorrect.

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Cause

When WinRE starts, it uses the Windows locale setting to set the display language. However, WinRE incorrectly uses the default input method to set the default keyboard layout. Therefore, an incorrect keyboard layout is used.

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Resolution

The hotfix that is described in this article resolves this issue in existing installations of Windows 8 and Windows RT. You can also integrate the hotfix into the Windows Imaging Format (WIM) file in your Windows RE environment to avoid this issue in future installations. To do this, follow these steps.

Notes
  1. Create the WinRE image (Winre.wim) by using a Windows 8 installation media. To do this, follow these steps:
    1. Copythe Install.wimfile fromthe Windows 8 installation media to a folder. For example, if the installation media is located on drive D, run the following commands at an elevated command prompt:
      md C:\OS_Image
      md C:\OS_Image\mount
      copy D:\sources\install.wim C:\OS_Image
    2. Mount the Install.wim file by using the DISM tool. To do this, run the following command:
      DISM /mount-wim /wimfile:C:\OS_Image\install.wim /index:1 /MountDir:C:\OS_Image\mount
    3. Copy the WinRE image (Winre.wim) from the mounted Windows 8 image to a folder. To do this, run the following commands:
      md C:\winre
      md C:\winre\mount
      copy C:\OS_image\mount\windows\system32\recovery\winre.wim C:\winre\
    4. Unmount the mounted Windows 8 image. To do this, run the following command:
      DISM /unmount-wim /MountDir:C:\OS_Image\mount /discard
  2. Copy the hotfix package to a folder.
  3. Integrate the hotfix into the WinRE image (Winre.wim). To do this, follow these steps:
    1. Mount the Winre.wim file that you created in step 1. To do this, run the following command:
      DISM /mount-wim /wimfile:C:\winre\winre.wim /index:1 /MountDir:C:\winre\mount
    2. Use the Add-package DISM option to insert the hotfix package into the mounted Winre.wim file.
    3. Confirm that the hotfix is integrated successfully. To do this, run the following command:
      DISM /image:C:\winre\mount /Get-Packages
    4. Commit the changes to the Winre.wim file. To do this, run the following command:
      DISM /unmount-wim /MountDir:C:\Winre\mount /commit
  4. Deploy the customized WinRE image.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows RT or Windows 8.

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any previously released updates.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows RT, Windows 8, and Windows Server 2012 file information notes
Important Windows 8 and Windows Server 2012 hotfixes are included in the same packages.
  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    VersionProductMilestoneService branch
    6.2.920 0.16 xxxWindows RT, Windows 8RTMGDR
    6.2.920 0.20 xxxWindows RT, Windows 8RTMLDR
  • GDR service branches contain only those fixes that are widely released to address widespread, critical issues. LDR service branches contain updates in addition to widely released fixes.
  • The MANIFEST files (.manifest) that are installed for each environment are listed separately in the "Additional file information for Windows RT and for Windows 8" section. MANIFEST files and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For Windows RT
File nameFile versionFile sizeDateTime
Bootrec.exe6.2.9200.16419271,36019-Sep-201206:20
Recenv.exe6.2.9200.16419535,55219-Sep-201205:51
Startrep.exe6.2.9200.16419552,96019-Sep-201205:51
For all supported x86-based versions of Windows 8
File nameFile versionFile sizeDateTime
Bootrec.exe6.2.9200.16419304,64019-Sep-201209:08
Recenv.exe6.2.9200.16419578,56019-Sep-201208:41
Startrep.exe6.2.9200.16419606,72019-Sep-201208:41
Bootrec.exe6.2.9200.20520304,64019-Sep-201206:37
Recenv.exe6.2.9200.20520578,56019-Sep-201206:09
Startrep.exe6.2.9200.20520606,72019-Sep-201206:10
For all supported x64-based versions of Windows 8
File nameFile versionFile sizeDateTime
Bootrec.exe6.2.9200.16419362,49619-Sep-201207:08
Recenv.exe6.2.9200.16419683,00819-Sep-201206:30
Startrep.exe6.2.9200.16419707,07219-Sep-201206:30
Bootrec.exe6.2.9200.20520362,49619-Sep-201207:06
Recenv.exe6.2.9200.20520683,00819-Sep-201206:28
Startrep.exe6.2.9200.20520707,07219-Sep-201206:28

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Workaround

To work around this issue, follow these steps:
  1. Enable the Eye option to read the text that you enter in the password box.
  2. Determine whether the keyboard layout is incorrect. 
  3. Select the correct keyboard layout by using the Change keyboard layout function.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows RT and for Windows 8

Additional files for Windows RT
File nameArm_4e6988be7c3e77a360176072882bb2b2_31bf3856ad364e35_6.2.9200.16419_none_7eabe0bbf8e7de2d.manifest
File versionNot applicable
File size699
Date (UTC)20-Sep-2012
Time (UTC)00:50
File nameArm_microsoft-windows-winre-tools_31bf3856ad364e35_6.2.9200.16419_none_c6fbceb94138cbf9.manifest
File versionNot applicable
File size5,622
Date (UTC)19-Sep-2012
Time (UTC)12:31
Additional files for all supported x86-based versions of Windows 8
File nameX86_40dc6c105f5ce74b623d47bc542b34e1_31bf3856ad364e35_6.2.9200.20520_none_69dba5b4a16f75a2.manifest
File versionNot applicable
File size699
Date (UTC)20-Sep-2012
Time (UTC)00:50
File nameX86_ce663b48e6a90e34aca2f91454a33c30_31bf3856ad364e35_6.2.9200.16419_none_a01e9a476597d9ac.manifest
File versionNot applicable
File size699
Date (UTC)20-Sep-2012
Time (UTC)00:50
File nameX86_microsoft-windows-winre-tools_31bf3856ad364e35_6.2.9200.16419_none_c6f95c61413bad33.manifest
File versionNot applicable
File size5,622
Date (UTC)19-Sep-2012
Time (UTC)10:49
File nameX86_microsoft-windows-winre-tools_31bf3856ad364e35_6.2.9200.20520_none_c76f26a65a6984df.manifest
File versionNot applicable
File size5,622
Date (UTC)19-Sep-2012
Time (UTC)08:25
Additional files for all supported x64-based versions of Windows 8
File nameAmd64_06265f0e87f5f7e54d31fc62e709c968_31bf3856ad364e35_6.2.9200.16419_none_8cdbb771c98ef024.manifest
File versionNot applicable
File size703
Date (UTC)20-Sep-2012
Time (UTC)00:50
File nameAmd64_4f94c156343ecbddbb8f2bf5ebafcbc4_31bf3856ad364e35_6.2.9200.20520_none_7fd7583ff937e7be.manifest
File versionNot applicable
File size703
Date (UTC)20-Sep-2012
Time (UTC)00:50
File nameAmd64_microsoft-windows-winre-tools_31bf3856ad364e35_6.2.9200.16419_none_2317f7e4f9991e69.manifest
File versionNot applicable
File size5,626
Date (UTC)19-Sep-2012
Time (UTC)13:04
File nameAmd64_microsoft-windows-winre-tools_31bf3856ad364e35_6.2.9200.20520_none_238dc22a12c6f615.manifest
File versionNot applicable
File size5,626
Date (UTC)19-Sep-2012
Time (UTC)09:51

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Keywords: kb, kbqfe, kbfix, kbsurveynew, kbexpertiseinter, kbautohotfix, kbhotfixserver

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Article Info
Article ID : 2758306
Revision : 1
Created on : 1/7/2017
Published on : 10/23/2012
Exists online : False
Views : 349