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Cannot delete objects from TFS if display language is Japanese.


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Symptoms


When trying to check-in a delete action in Version Control you received an error simillar to this  -

\\Forms\SalesTables is already checked in.
Unable to check in.


If users use Team Foundation Server for development in Dynamics AX and AX developer's client uses Japanese as display language, this issue happens. This document assumes all setup of TFS was done on AX Developer's client machines.


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Cause

Keyword unmatch due to language setting on the workstation is not English. When trying to check-in a deletion action, the keyword expected is "delete" but since the OS's display language is Japanese, it returns [delete] in Japanese characters. 

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Resolution

If users hit this issue, please use the following simple workaround.

Edit the following -
Class\SysVersionControlSystemFileBased\checkInChangelist method.

Add following codes in order to translate action text in English.
Resolving code

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More Information

After this change you also need to check KB Article Number (s) : 2752300. This cleans up the local clients TFS's repository when AOT objects actually deleted from TFS server.


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Keywords: kbmbspartner, kbmbsmigrate, kbsurveynew, kb

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Article Info
Article ID : 2757528
Revision : 1
Created on : 1/7/2017
Published on : 11/5/2012
Exists online : False
Views : 228