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An error occurs when trying to Load Data in Microsoft Dynamics CRM E-mail Router


Symptoms

When clicking on Load Data, the error message below may occur:

"The Email Router Configuration Manager was unable to retrieve user and queue information from the Microsoft Dynamics CRM server. This may indicate that the Microsoft Dynamics CRM server is busy. Verify that URL 'https://disco.crm.dynamics.com/OrganizationUniqueName' is correct. Additionally, this problem can occur if specified access credentials are insufficient. To try again, click Load Data. (LogonIdentityExWithUI())".

Additionally, the following error is part of the E-mail Router Tracing:

"01/01/2012 12:00:00 : #6188 - The E-mail Router service cannot connect to the Microsoft Dynamics CRM server or the Microsoft Dynamics CRM Online server to access user and queue information. Verify that the account that is used to run the E-mail Router service has sufficient permission to access the Microsoft Dynamics CRM server and that there are no connectivity problems. Microsoft.Crm.Passport.IdCrl.IdCrlException: IntializationFailure"

 

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Cause

The latest Microsoft Dynamics CRM E-mail Router Update Rollup and Microsoft Online Services Sign-In Assistant for IT Professionals RTW are not installed on the Microsoft Dynamics CRM E-mail Router server.

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Resolution

In order to resolve this problem, install the latest Microsoft Dynamics CRM E-mail Router update rollup along with the Microsoft Online Services Sign-In Assistant for IT Professionals RTW on the Microsoft Dynamics CRM E-mail Router server.

Microsoft Dynamics CRM 2011 updates and hotfixes
http://support.microsoft.com/kb/2555051

Microsoft Online Services Sign-In Assistant for IT Professionals RTW
http://www.microsoft.com/en-us/download/details.aspx?id=28177

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More Information

The stack trace may display the following:

Server stack trace:
   at Microsoft.Crm.ServiceProxyCache`1.BuildServiceProxy(Uri serviceUrl, Credential credentials, Uri homeRealmUrl, String passportEnvironment, String onlineServiceEnvironment, IServiceConfiguration`1 serviceConfiguration)
   at Microsoft.Crm.ServiceProxyCache`1.GetNewServiceProxy(Uri serviceUrl, Credential credentials, Uri homeRealmUrl, String passportEnvironment, String onlineServiceEnvironment)
   at Microsoft.Crm.Tools.Email.Providers.OrganizationUrlCache.DiscoverOrganizationUrl(Uri discoveryServiceUrl, Credential credentials, String organizationName)
   at System.Lazy`1.CreateValue()

In order to enable the E-mail Router Tracing, follow the article below:

How to enable tracing in Microsoft Dynamics CRM
http://support.microsoft.com/kb/907490

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Article Info
Article ID : 2755658
Revision : 1
Created on : 1/8/2017
Published on : 9/14/2012
Exists online : False
Views : 71