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System event log errors every 15 minutes on a Windows Server 2008 R2-based Cluster configured with Node Majority and File Share Witness quorum


View products that this article applies to.

Symptoms

Assume that you configure a quorum model to Node Majority and to File Share Witness resource on a Windows Server 2008 R2-based Cluster service. In this situation, you receive Event IDs 1558 and 1069 in the system event log every 15 minutes. For example, you receive the following event logs:


The issue occurs when the following registry key for Restart Policy is set to 1 on all nodes:HKEY_LOCAL_MACHINE\Cluster\Quorum\WitnessFailed
Note
The issue is not resolved when you set the registry key to 0.

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Cause

This issue occurs because the Cluster service uses a restart policy to monitor and recover from failures of the Witness resource. When a failure occurs, the Restart Policy tries to restart the Witness resource after a 15 minutes time interval. However, if the Witness resource is not storage capable, the Cluster service cannot set the restart policy to a success state after the Witness resource is restarted. Therefore, the failure occurs again after 15 minutes and keeps repeating every 15 minutes.

Note By default, the restart policy is configured to restart the Witness resource every 15 minutes. You can reconfigure the time interval by using the WitnessRestartInterval cluster property. For more information about the WitnessRestartInterval cluster property, go to the following Microsoft website:

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Resolution

This hotfix is also available at Microsoft Update Catalog.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2008 R2 Service Pack 1 (SP1). For more information about how to obtain a Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To apply this hotfix, you do not have to change the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    VersionProductMilestoneService branch
    6.1.760
    1.22xxx
    Windows Server 2008 R2SP1LDR
  • GDR service branches contain only those fixes that are widely released to address widespread, critical issues. LDR service branches contain hotfixes in addition to widely released fixes.
  • The MANIFEST files (.manifest) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2" section. MANIFEST files and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTime
Clussvc.exe6.1.7601.221054,619,26403-Sep-201215:17
Cluswmi.dll6.1.7601.22105542,20804-Sep-201206:54
Cluswmi.mofNot applicable76,75203-Sep-201211:18
Cluswmiuninstall.mofNot applicable17603-Sep-201211:18
Cluswmi.dll.mui6.1.7601.2210515,87204-Sep-201206:57
Cluswmi.mflNot applicable173,68404-Sep-201207:09
For all supported IA-64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTime
Clussvc.exe6.1.7601.221057,776,76803-Sep-201214:50
Cluswmi.dll6.1.7601.22105886,78404-Sep-201206:15
Cluswmi.mofNot applicable76,75203-Sep-201211:14
Cluswmiuninstall.mofNot applicable17603-Sep-201211:14
Cluswmi.dll.mui6.1.7601.2210515,87204-Sep-201206:27
Cluswmi.mflNot applicable173,68404-Sep-201206:26

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Workaround

To work around this issue, use one of the following methods:
  • Perform a reform on cluster nodes to clear the failed status in the restart policy object. 
    Note A reform occurs when all the nodes are shut down or all cluster service on every node are shut down at the same time. 
  • Switch the quorum model to the storage capable quorum model temporarily. After the issue is resolved, you can switch the quorum model back to the original quorum model.
Note After you work around the issue by using one of earlier methods, the issue might reoccur.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2
File nameAmd64_0a48f48b72d20109b5948de0e23d220d_31bf3856ad364e35_6.1.7601.22105_none_d9bafce4a664a1a5.manifest
File versionNot applicable
File size723
Date (UTC)04-Sep-2012
Time (UTC)13:28
File nameAmd64_0ffa7c9436fd0ed1d4d47d1e3bcac669_31bf3856ad364e35_6.1.7601.22105_none_1e7da996ee210c5b.manifest
File versionNot applicable
File size723
Date (UTC)04-Sep-2012
Time (UTC)13:28
File nameAmd64_microsoft-windows-f..overcluster-clussvc_31bf3856ad364e35_6.1.7601.22105_none_187cfb77d1401cef.manifest
File versionNot applicable
File size7,438
Date (UTC)04-Sep-2012
Time (UTC)08:01
File nameAmd64_microsoft-windows-f..overcluster-cluswmi_31bf3856ad364e35_6.1.7601.22105_none_1b2af4bbcf85b6cc.manifest
File versionNot applicable
File size6,668
Date (UTC)04-Sep-2012
Time (UTC)07:57
File nameAmd64_microsoft-windows-f..r-cluswmi.resources_31bf3856ad364e35_6.1.7601.22105_en-us_a96fb561cb0bda69.manifest
File versionNot applicable
File size3,079
Date (UTC)04-Sep-2012
Time (UTC)07:29
File nameWow64_microsoft-windows-f..overcluster-clussvc_31bf3856ad364e35_6.1.7601.22105_none_22d1a5ca05a0deea.manifest
File versionNot applicable
File size4,604
Date (UTC)04-Sep-2012
Time (UTC)06:43
Additional files for all supported IA-64-based versions of Windows Server 2008 R2
File nameIa64_78e23e17624ac045b6218f9eaf1a8d61_31bf3856ad364e35_6.1.7601.22105_none_53aae87518d89798.manifest
File versionNot applicable
File size721
Date (UTC)04-Sep-2012
Time (UTC)13:28
File nameIa64_8e3d10828a79d0e0298ebd71d6751736_31bf3856ad364e35_6.1.7601.22105_none_d361000e19682dd8.manifest
File versionNot applicable
File size1,070
Date (UTC)04-Sep-2012
Time (UTC)13:28
File nameIa64_f2cda8adbe05f668c8ceb9f9270abd38_31bf3856ad364e35_6.1.7601.22105_none_bd81f50a9154909b.manifest
File versionNot applicable
File size721
Date (UTC)04-Sep-2012
Time (UTC)13:28
File nameIa64_microsoft-windows-f..overcluster-clussvc_31bf3856ad364e35_6.1.7601.22105_none_bc6003ea18e0b4b5.manifest
File versionNot applicable
File size7,436
Date (UTC)04-Sep-2012
Time (UTC)08:01
File nameIa64_microsoft-windows-f..overcluster-cluswmi_31bf3856ad364e35_6.1.7601.22105_none_bf0dfd2e17264e92.manifest
File versionNot applicable
File size6,666
Date (UTC)04-Sep-2012
Time (UTC)07:59
File nameIa64_microsoft-windows-f..r-cluswmi.resources_31bf3856ad364e35_6.1.7601.22105_en-us_4d52bdd412ac722f.manifest
File versionNot applicable
File size3,078
Date (UTC)04-Sep-2012
Time (UTC)06:42
File nameWow64_microsoft-windows-f..overcluster-clussvc_31bf3856ad364e35_6.1.7601.22105_none_22d1a5ca05a0deea.manifest
File versionNot applicable
File size4,604
Date (UTC)04-Sep-2012
Time (UTC)06:43

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Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbexpertiseadvanced, kbsurveynew

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Article Info
Article ID : 2750820
Revision : 3
Created on : 9/28/2018
Published on : 9/28/2018
Exists online : False
Views : 189