Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Servers running Windows Server 2012 and Windows Server 2008 R2 may encounter a non-maskable interrupt (NMI) error when resuming from hibernation


View products that this article applies to.

Symptoms


When resuming from hibernation on a server that is running Windows Server 2012 or Windows Server 2008 R2, you may receive a non-maskable interrupt (NMI) error message.

↑ Back to the top


Cause

Firmware that performs input/output (I/O) while the operating system is in S4 (hibernate) can cause system resources to become stale and out of sync.

↑ Back to the top


Resolution

It is not recommended that firmware perform any device I/O while the system is in S4 (hibernate). Operating System Capabilities (SYSTEM_POWER_CAPABILITIES) data structure needs to reflect that S4 is NOT supported and users are prevented from placing the system into hibernation. 

↑ Back to the top


More Information

When Windows is resuming from S4, there is early logic that must ensure Peripheral Component Interconnect Express (PCIe) range resources match the values present when the system previously transitioned to S4. This is because the operating system may have rebalanced those resources, and the S4-resume firmware phase will have re-initialized the resources to a stale state. It is during this phase that any device I/O that may happen outside the operating system's control can be problematic.


Options
This section outlines options to avoid conflicting ownership of devices across an S4 operation. This section assumes a management agent is necessary and present.  It also assumes a Windows operating system is present.


It is recommended the user not allow the platform to enter into an S4 (hibernation) state if the platform vendors firmware requires performing input/output (I/O) while in this state. It is recommended that you contact hardware manufacturer for any additional support if you are encountering this issue.


↑ Back to the top


Keywords: kb

↑ Back to the top

Article Info
Article ID : 2749546
Revision : 1
Created on : 1/7/2017
Published on : 10/30/2012
Exists online : False
Views : 231