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FIX: The 3270 client displays garbled characters when it first connects to an IBM mainframe application in a Host Integration Server environment


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You use the Microsoft Host Integration Server 3270 client (Win3270.exe) that is included in Microsoft Host Integration Server 2009 and Host Integration Server 2010.
  • You configure the 3270 client to use an IBM double-byte character set (DBCS) host code page. For example, you use code page 930 (IBM extend katakana and IBM Japanese).
  • The 3270 client connects to an IBM mainframe application for the first time.
In this scenario, the 3270 client displays garbled characters.

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Cause

This issue occurs because the 3270 client does not correctly initialize DBCS host code pages during the initial connection process.

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Resolution

To resolve this problem, apply either the cumulative update or the hotfix that is mentioned in this article.

Host Integration Server 2010

Cumulative update information

The fix that resolves this issue is included in cumulative update package 6 for Host Integration Server 2010. For more information about how to obtain the cumulative update package, click the following article number to view the article in the Microsoft Knowledge Base:
2752426 Cumulative update package 6 for Host Integration Server 2010

Host Integration Server 2009

Cumulative update information

The hotfix that resolves this issue is included in cumulative update package 4 for Host Integration Server 2009.



For more information about how to obtain the cumulative update package, click the following article number to view the article in the Microsoft Knowledge Base:

2765212 Cumulative update package 4 for Host Integration Server 2009

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Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have cumulative update package 5 for Host Integration Server 2010 or cumulative update package 3 for Host Integration Server 2009 installed.

Restart information

You do not have to restart the computer after you apply this hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

For Host Integration Server 2010

For all supported x86-based versions of Host Integration Server 2010
File nameFile versionFile sizeDateTimePlatform
Win3270.exe8.5.4606.2162,00807-Sep-201222:34x86
For all supported x64-based versions of Host Integration Server 2010
File nameFile versionFile sizeDateTimePlatform
Win3270.exe8.5.4606.2162,00807-Sep-201222:36x86
Win3270.exe8.5.4606.2207,57607-Sep-201222:36x64

For Host Integration Server 2009

For all supported x86-based versions of Host Integration Server 2009
File nameFile versionFile sizeDateTimePlatform
Win3270.exe8.0.3978.2153,81611-Sep-201218:09x86
For all supported x64-based versions of Host Integration Server 2009
File nameFile versionFile sizeDateTimePlatform
Win3270.exe8.0.3978.2153,81611-Sep-201218:09x86
Win3270.exe8.0.3978.2207,57611-Sep-201218:12x64
Note Because of file dependencies, the most recent fix that contains these files may also contain additional files.




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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

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Workaround

To work around this issue, use one of the following methods:
  • Start the 3270 client by using a non-DBCS host code page. Then, reconfigure the 3270 Client to use a DBCS host code page.
  • Start the 3270 client, change the host code page setting, and then change back to the DBCS host code page before the 3270 client connects to the mainframe application.

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Keywords: kb, kbqfe, kbhotfixserver, kbfix, kbautohotfix, kbexpertiseadvanced, kbsurveynew, kbseo

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Article Info
Article ID : 2749443
Revision : 1
Created on : 1/7/2017
Published on : 12/19/2012
Exists online : False
Views : 308