Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

The process may fail when you try to enable load balancing in DirectAccess in Window Server 2012


View products that this article applies to.

Symptoms

When you try to enable Windows Network Load Balancing (NLB) or External Load Balancing (ELB) in DirectAccess in Windows Server 2012, the process may fail. Additionally, you may receive the following error message.  

Note The IPv6 addresses that appear in the message that you receive may differ from the addresses that are shown here.  

Required IP addresses have not been provided. Specify at least fde5:5b9:700e:2222::1, fde5:5b9:700e:2222::2 as InternetVirtualIPAddress.

↑ Back to the top


Cause

This issue can occur when the following conditions are true:
  • The Use force tunneling option is enabled
  • The DirectAccess deployment is a single-site (not multisite) deployment.
This is a known issue with DirectAccess in Windows Server 2012.

↑ Back to the top


Workaround

To work around this issue, disable the Use force tunneling option, and apply this change before you try to enable NLB or ELB. After NLB or ELB is configured, you can reenable the Use force tunneling option. 

↑ Back to the top


More Information

If you cannot temporarily disable force tunneling in a production environment, you can use staging GPOs for DirectAccess to let the configuration changes occur without production clients being affected. 

For more information about staging GPOs, see section 1.8.4 of the "Plan the Remote Access Infrastructure" documenation. This documentation is available at the following Microsoft TechNet website:

Or, you can use sample scripts to work around the issue by changing the DirectAccess server GPO directly. The scripts temporarily change the registry value that is causing the load-balancing checks to fail. For more information about these scripts, go to the following TechNet website: 


Note These scripts are not supported under any Microsoft standard support program or service. The sample scripts are provided "as is" without warranty of any kind. Microsoft disclaims all implied warranties including, without limitation, any implied warranties of merchantability or of fitness for a particular purpose. The whole risk arising out of the use or performance of the sample scripts and documentation remains with you. In no event shall Microsoft, its authors, or anyone else involved in the creation, production, or delivery of the scripts be liable for any damages whatsoever (including, without limitation, damages for loss of business profits, business interruption, loss of business information, or other pecuniary loss) arising out of the use of or inability to use the sample scripts or documentation, even if Microsoft has been advised of the possibility of such damages. 


↑ Back to the top


Keywords: kb

↑ Back to the top

Article Info
Article ID : 2748603
Revision : 1
Created on : 1/7/2017
Published on : 10/23/2013
Exists online : False
Views : 308