Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

"Searching for available RemoteApp Programs" message is displayed indefinitely on the RD Web Access webpage


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You configure a Remote Desktop (RD) Web Access server on a computer that is running Windows Server 2012.
  • You configure the ShowDesktops setting to False in Internet Information Services (IIS) Manager.

    Note�This action disables the�Connect to a remote PC tab on the RD Web Access webpage.
  • A user signs in to the RD Web Access webpage and tries to start a remote connection.
In this scenario, the user cannot start a remote connection. Specifically, the following message is displayed indefinitely:
Searching for available RemoteApp Programs

↑ Back to the top


Cause

This is a known issue in Windows Server 2012.

↑ Back to the top


Workaround

To work around this issue, follow these steps:
  1. On the RD Web Access server, open the following file:
    %WINDIR%\Web\RDWeb\Pages\Site.xsl
  2. Locate line 380.
  3. Change if (ActiveXMode) to the following text:

    if (ActiveXMode &amp;&amp; <xsl:value-of select="$feedidprefix"/>Controls.PORTAL_REMOTE_DESKTOPS != null)

↑ Back to the top


Keywords: KB2743682, kbexpertiseadvanced, kbsurveynew, kbprb

↑ Back to the top

Article Info
Article ID : 2743682
Revision : 3
Created on : 10/26/2012
Published on : 10/26/2012
Exists online : False
Views : 440