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FIX: An XAML file may not load correctly after you edit a Team Foundation Server build in Workflow Designer for Visual Studio Team Explorer 2010


Symptoms

After you edit a Team Foundation Server (TFS) build in Workflow Designer for Microsoft Visual Studio Team Explorer 2010, the XAML file may not load correctly in the Build Definition editor or on your build server that is running Microsoft Visual Studio Team Foundation Server 2012.

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Cause

This problem occurs because, when you edit a TFS build in Workflow Designer for Team Explorer 2010, additional namespaces that contain version information are added to the XAML file. This version information may cause the XAML file not to load correctly.

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Resolution

Hotfix information

A supported hotfix is now available from Microsoft. However, it is intended to correct only the problem that is described in this article. Apply it only to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

To resolve this problem immediately, contact Microsoft Customer Support Services to obtain the hotfix. For a complete list of Microsoft Customer Support Services telephone numbers and information about support costs, visit the following Microsoft website:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

You must have Microsoft Visual Studio 2010 Service Pack 1 (SP1) installed to apply this hotfix.

For more information about Visual Studio 2010 SP1, click the following article number to view the article in the Microsoft Knowledge Base:
983509 Description of Visual Studio 2010 Service Pack 1

Restart information

You do not have to restart the computer after you apply this hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

File nameFile versionFile sizeDateTimePlatform
Microsoft.teamfoundation.build.server.logger.dll10.0.40219.42649,33629-Sep-201216:28x86
Microsoft.teamfoundation.build.workflow.dll10.0.40219.426660,65629-Sep-201216:28x86
Tfsbuildservicehost.exe10.0.40219.426192,62429-Sep-201216:28x86


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Workaround

To work around this problem, manually remove the additional namespaces that were added by Workflow Designer for Visual Studio Team Explorer 2010.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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Applies to

This article applies to the following:
  • Microsoft Visual Studio Team Explorer 2010

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Keywords: kbqfe, kbhotfixserver, kbfix, kbnotautohotfix, kbexpertiseinter, kbsurveynew, kbbug, kb

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Article Info
Article ID : 2743227
Revision : 2
Created on : 9/19/2018
Published on : 9/19/2018
Exists online : False
Views : 76