Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

XADM: Service Pack Setup Does Not Work with


View products that this article applies to.

This article was previously published under Q274197
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 (http://support.microsoft.com/kb/256986/EN-US/) Description of the Microsoft Windows Registry

↑ Back to the top


Symptoms

If you remove Microsoft Outlook Web Access (OWA) and Microsoft Internet Information Services (IIS) 4.0 manually from an Exchange Server computer, and then you try to install an Exchange Server service pack, the service pack installation may not work and you may receive the following error message:
System cannot find the file specified
Microsoft Windows NT
ID No: 0xc0020002
No messages are logged in the Application event log or System event log.

↑ Back to the top


Cause

This issue can occur if you remove IIS and OWA by deleting the HKEY_LOCAL_MACHINE/System/CCS/Services/MSExchangeWEB key and by deleting the Webdata, Webdata.bak, and Webtemp folders.

When you run the service pack installation, Setup displays a message that Setup is backing up the Webdata folder and stops responding immediately afterward. The MSExchangeWEB key is also re-created with no values.

↑ Back to the top


Resolution

To resolve this issue, delete the Web Connector registry key.

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

To delete the Web Connector registry key:
1.Start Registry Editor (Regedt32.exe).
2.Locate and click the following key in the registry:
HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\Setup\Web Connector
3.On the Edit menu, click Delete.
4.Quit Registry Editor.

↑ Back to the top


More information

Setup for Exchange Server service packs checks for installed components in the Setup key. If the Web Connector key is present, Setup proceeds as if OWA is installed; therefore, Setup immediately stops responding because IIS is no longer present.

↑ Back to the top


Keywords: KB274197, kbprb

↑ Back to the top

Article Info
Article ID : 274197
Revision : 6
Created on : 10/28/2006
Published on : 10/28/2006
Exists online : False
Views : 339