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Unable to edit the Sales Activity Dashboard in Microsoft Dynamics CRM 2011


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Symptoms

 When attempting to open or edit the Sales Performance Dashboard in Microsoft Dynamics CRM 2011, the following error may occur:

"Cannot Edit Dashboard. The Dashboard could not be opened. Maximum no. of columns allowed in the layout is 4."

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Cause

The dashboard editor does not allow dashboards with more than three columns. The dashboard editor was designed to not allow editing, as increasing these values will cause script errors within the dashboards. 

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Resolution

This can be modified using the Solution export and re-import (un-managed) functionality.

1. Save this dashboard as a new dashboard. (Use the Save As button on the tool-bar)

2. Create a solution containing the new dashboard.

3. Create a new solution, add the new dashboard to it, and export this solution.

4. Under the dashboards node in the customizations.xml, reach the dashboard xml (FormXml node) and change the columns attribute of section to "111" as shown below:

<sectionshowlabel="false"showbar="false"columns="111"

5. For each cell, the current "colspan" is in the following order: 2,1,2,3,2,3. Change this to 1,1,1,2,1,2. For example:

<cellcolspan="2"rowspan="24"

6. Save the file and zip the solution again to re-import back.

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Keywords: kbmbspartner, kbmbsmigrate, kbsurveynew, kb

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Article Info
Article ID : 2741768
Revision : 1
Created on : 1/7/2017
Published on : 11/16/2012
Exists online : False
Views : 229