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Outlook for Mac search returns "No Results," and task items are not displayed


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Symptoms

In Microsoft Outlook 2016 for Mac or Office for Mac 2011, you receive a "No Results" message when you try to search for an email message or apply a filter to a folder, and task items are not displayed in the Tasks folder. Additionally, when you search for mail items by using the Mac OS native Spotlight Search, your search is unsuccessful.

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Cause

This issue may occur for one of the following reasons:


Microsoft Outlook 2016 for Mac:
  • Spotlight Search indexing is incomplete.
  • The Profile name contains special characters such as the slash mark (/).
  • The Profile or one of its parent folders are added to the Privacy tab in Spotlight.
  • The Outlook 15 Profiles folder is not located under ~/Library/Group Containers/UBF8T346G9.Office/Outlook.
  • The Spotlight Search index is corrupted.


Microsoft Outlook for Mac 2011:
  • Spotlight Search indexing is incomplete. 
  • The Identity name contains special characters such as the slash mark (/).
  • The Identity or one of its parent folders are added to the Privacy tab in Spotlight.
  • The Microsoft User Data folder is not located under the ~/Documents folder.
  • The Spotlight Search index is corrupted.

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Resolution

To resolve this issue, follow these steps:

  1. Run the OutlookSearchRepair utility. For more information about how to get and run the utility, go to the Mac Outlook Support Utilities blog on the Microsoft TechNet website.
  2. If you recently created a new Outlook Profile in Outlook 2016 for Mac, or a new Identity in Outlook for Mac 2011, added a new account, or if you recently imported new data from a source such as a PST or OLM file, Spotlight indexing may not be complete. In this case, Outlook for Mac displays a "No Results" message. To resolve this issue, wait for indexing to finish, and then search again.
  3. Make sure that your Profile name in Outlook 2016 for Mac or your Identity name in Outlook for Mac 2011 has no special characters, such as the slash mark (/). 
    To view your Profile or Identity name:
    Outlook 2016 for Mac:
     
    1. Click GoApplications.
    2. Right-Click Microsoft Outlook, and select Show Package Contents.
    3. Expand ContentsSharedSupport, and open Outlook Profile Manager.

    Note You can create an alias for the Outlook Profile Manager, and move it to your desktop or another convenient location if you prefer.

    Outlook for Mac 2011:

    To view your Identity names in the Microsoft Database Utility, hold down the Option key, and then click the Outlook for Mac 2011 icon.
  4. If the Profile or Identity name contains a special character, follow these steps to change the name:
    1. Open the Outlook 2016 for Mac Profile folder or Outlook for Mac 2011 Identity folder.
      In Outlook 2016 for Mac, the location is: 
      /Users/<Username>/Library/Group Containers/UBF8T346G9.Office/Outlook/Outlook 15 Profiles/

      In Outlook for Mac 2011, the location is:
      Users/<Username>/Documents/Microsoft user data/Office 2011 Identities/
    2. Rename the Outlook 2016 for Mac Profile folder name or the Outlook for Mac 2011 Identity folder name that contains special characters by removing the special characters.
    3. Confirm that the Profile or Identity name was changed by viewing it in the following way depending on your version of Outlook for Mac:
       
      In Outlook 2016 for Mac
      :
       
      1. Click Go, Applications.
      2. Right-Click Microsoft Outlook, and select Show Package Contents.
      3. Expand Contents, SharedSupport, and open Outlook Profile Manager.

      Note You can create an alias for the Outlook Profile Manager, and move it to your desktop or another convenient location if you prefer.

      In Outlook for Mac 2011:

      Open the Microsoft Database Utility by holding down the Option key, and then clicking the Outlook for Mac 2011 icon.
    4. If necessary, select the Profile or Identity whose name was changed, click the Gear icon, and then click Set as Default.
  5. Verify in Mac OS that the Outlook Profile or Identity folder or one of its parent folders is not added to the Privacy tab in Spotlight. If your Outlook 2016 for Mac Profiles folder, or your Outlook for Mac 2011 Identity folder, or any of their parent folders are displayed in this tab, Spotlight does not index this folder location. Remove these locations from the Privacy tab in Spotlight, and allow for time for these locations to finish indexing.
  6. Make sure the Outlook 2016 for Mac Profile or Outlook for Mac 2011 Identity data is stored under the correct default location.
     
    Outlook 2016 for Mac: Make sure that the Outlook 15 Profiles folder is stored under the ~/Library/Group Containers/UBF8T346G9.Office/Outlook folder.

    Outlook for Mac 2011: Make sure that the Microsoft User Data folder is stored under the ~/Documents folder.
  7. If the issue is still unresolved, the Spotlight index may be corrupted. To reindex the Spotlight index, follow these steps:
    1. Restart the Mac, so that it restarts the Spotlight services.
    2. Navigate to Finder > ApplicationsUtilities > Terminal.
    3. Type mdimport -L.
    4. Important: If you see more than one instance of "Microsoft Outlook Spotlight Importer.mdimporter," delete the Outlook application that you are not using, empty it from the Trash, restart your Mac, and go back to step 1.
    5. In the Terminal, reindex your Outlook database by using the following command and substituting your own user name for the <user_name> placeholder:

      mdimport -g "/Applications/Microsoft Outlook.app/Contents/Library/Spotlight/Microsoft Outlook Spotlight Importer.mdimporter" -d1 "/Users/<user_name>/Library/Group Containers/UBF8T346G9.Office/Outlook/Outlook 15 Profiles/<my_profile_name>" 

      Note In this command, the path after "-g" is the default path of the Outlook installation. The path after "-d1" is the default path of your profile, where <my_profile_name> is, by default “Main Profile." You'll have to substitute your actual paths if you have renamed your profile or installed Outlook in a different location.
    6. Reindexing will take some time to complete. After the process is complete, exit and then restart Outlook. 

If you still cannot search in Spotlight after you follow these steps, and if you have allowed for enough time for Spotlight Indexing to be completed, you may have to uninstall Office for Mac and reinstall it. For more information about how to do this, click the following article number to view the article in the Microsoft Knowledge Base: 

2398768 How to completely remove Office for Mac 2011

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More Information

When you search in Outlook 2016 for Mac or Outlook for Mac 2011 on Mac OS X, be aware of the following:
  • Mac OS includes Spotlight Search. Mac OS controls the indexing of the hard disk for Spotlight Search.
  • Both versions of Outlook for Mac rely on Spotlight Search to provide search results for Outlook data. 
  • The filters in Outlook for Mac also rely on Spotlight Search to provide search results.
  • Tasks in Outlook for Mac are displayed by using filters. These filters rely on Spotlight Search.
  • Spotlight indexing may take several minutes when new data is introduced. For example, this may occur when new email messages are received.
Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information. 

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

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Keywords: kb

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Article Info
Article ID : 2741535
Revision : 16
Created on : 5/20/2019
Published on : 5/20/2019
Exists online : False
Views : 354