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You cannot add network adapters to a virtual machine on a Windows Server 2008 R2-based failover cluster


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You create a failover cluster on some computers that are running Windows Server 2008 R2 SP1.
  • You enable the Hyper-V role on both cluster nodes.
  • You configure a virtual machine as a cluster resource.
  • You try to add a network adapter to the virtual machine by using the Refresh Virtual Machine Configuration wizard.
In this scenario, you cannot add the network adapter successfully until the virtual machine is removed from the cluster.

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Cause

This issue occurs because of an exception that occurs during the configuration process. In this situation, the control code that updates the virtual switches is not sent.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2008 R2 SP1.
For more information about how to obtain a Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
976932 Information about Service Pack 1 for Windows Server 2008 R2

Registry information

To apply this hotfix, you do not have to change the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2008 R2 file information notes
  • The files that apply to a specific product, milestone (RTM,SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    VersionProductMilestoneService branch
    6.1.760 1.22xxxWindows Server 2008 R2SP1LDR
  • GDR service branches contain only those fixes that are widely released to address widespread, critical issues. LDR service branches contain hotfixes in addition to widely released fixes.
  • The MANIFEST files (.manifest) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2" section. MANIFEST files and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Failoverclusters.wizards.dll6.1.7601.22130659,45609-Oct-201218:42x86
For all supported IA-64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Failoverclusters.wizards.dll6.1.7601.22130659,45609-Oct-201217:33x86

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2
File nameAmd64_microsoft-windows-f..overcluster-wizards_31bf3856ad364e35_6.1.7601.22130_none_9ee8c77a3276bb58.manifest
File versionNot applicable
File size2,500
Date (UTC)09-Oct-2012
Time (UTC)19:15
PlatformNot applicable
Additional files for all supported IA-64-based versions of Windows Server 2008 R2
File nameIa64_f1e1c97ff72f5618432199a07dd6ab19_31bf3856ad364e35_6.1.7601.22130_none_3d990effcea2e73c.manifest
File versionNot applicable
File size713
Date (UTC)09-Oct-2012
Time (UTC)21:04
PlatformNot applicable
File nameIa64_microsoft-windows-f..overcluster-wizards_31bf3856ad364e35_6.1.7601.22130_none_42cbcfec7a17531e.manifest
File versionNot applicable
File size2,498
Date (UTC)09-Oct-2012
Time (UTC)18:59
PlatformNot applicable

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Keywords: kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseadvanced, KB2741477

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Article Info
Article ID : 2741477
Revision : 2
Created on : 1/29/2013
Published on : 1/29/2013
Exists online : False
Views : 322