Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

The BITS service stops responding when you try to stop the service on a Windows 8-based or Windows Server 2012-based device


View products that this article applies to.

Symptoms

Assume that you try to stop the Background Intelligent Transfer Service (BITS) service manually on a Windows 8-based or Windows Server 2012-based device shortly after you start the device. In this situation, the BITS service stops responding.

Note This issue does not occur if you stop the BITS service while the device is shutting down.

↑ Back to the top


Cause

This issue occurs because of a race condition between the cancellation of the Internet Gateway Device (IGD) device search and the callback function that is generated when the device search finishes.

Resolution

To resolve this issue, restart the device.

↑ Back to the top


Keywords: KB2734827, kbsurveynew, kbexpertiseinter, kbprb

↑ Back to the top

Article Info
Article ID : 2734827
Revision : 1
Created on : 8/2/2012
Published on : 8/2/2012
Exists online : False
Views : 305