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Computer stops responding after you connect to an SMB 1 server in Windows 7 or in Windows Server 2008 R2


View products that this article applies to.

Symptoms

Assume that you connect to a server that is running Server Message Block (SMB) 1 from a client computer that is running Windows 7 or Windows Server 2008 R2. In this situation, the client computer may stop responding.

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Cause

This issue occurs if the SMB client computer runs out of nonpaged pool memory. An I/O request packet (IRP) is allocated but is never released in the Mrxsmb10.sys driver.

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Resolution

This hotfix is also available at Microsoft Update Catalog.

Hotfix information

Important This hotfix has been re-released to address an issue in which the digital signature on files produced and signed by Microsoft will expire prematurely, as described in Microsoft Security Advisory 2749655.

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows 7 Service Pack 1 (SP1) or Windows Server 2008 R2 SP1. For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 7 and Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    VersionProductMilestoneService branch
    6.1.760 1.22xxxWindows 7 and Windows Server 2008 R2SP1LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows 7 and for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are critical to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
File nameFile versionFile sizeDateTimePlatform
Mrxsmb10.sys6.1.7601.22033223,74428-Jun-201208:08x86
For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Mrxsmb10.sys6.1.7601.22033288,76828-Jun-201208:28x64
For all supported IA-64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Mrxsmb10.sys6.1.7601.22033678,40028-Jun-201207:50IA-64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7
File nameUpdate.mum
File versionNot Applicable
File size2,136
Date (UTC)17-Sep-2012
Time (UTC)12:46
PlatformNot Applicable
File nameX86_085b5c5669890c1cf3596b0883437648_31bf3856ad364e35_6.1.7601.22033_none_92d288b0692110b9.manifest
File versionNot Applicable
File size701
Date (UTC)17-Sep-2012
Time (UTC)12:46
PlatformNot Applicable
File nameX86_microsoft-windows-smb10-minirdr_31bf3856ad364e35_6.1.7601.22033_none_8b1ecff1c2dfaf9c.manifest
File versionNot Applicable
File size3,962
Date (UTC)28-Jun-2012
Time (UTC)15:40
PlatformNot Applicable
Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameAmd64_edb9be438bf6b4abb5e29405fb414f0e_31bf3856ad364e35_6.1.7601.22033_none_52fd3a3b54e47a9b.manifest
File versionNot Applicable
File size705
Date (UTC)17-Sep-2012
Time (UTC)12:46
PlatformNot Applicable
File nameAmd64_microsoft-windows-smb10-minirdr_31bf3856ad364e35_6.1.7601.22033_none_e73d6b757b3d20d2.manifest
File versionNot Applicable
File size3,966
Date (UTC)28-Jun-2012
Time (UTC)16:33
PlatformNot Applicable
File nameUpdate.mum
File versionNot Applicable
File size2,350
Date (UTC)17-Sep-2012
Time (UTC)12:46
PlatformNot Applicable
Additional files for all supported IA-64-based versions of Windows Server 2008 R2
File nameIa64_cef4cf563f5623f8b1e6d9632937959a_31bf3856ad364e35_6.1.7601.22033_none_7944e7af42f53b14.manifest
File versionNot Applicable
File size703
Date (UTC)17-Sep-2012
Time (UTC)12:46
PlatformNot Applicable
File nameIa64_microsoft-windows-smb10-minirdr_31bf3856ad364e35_6.1.7601.22033_none_8b2073e7c2ddb898.manifest
File versionNot Applicable
File size3,964
Date (UTC)28-Jun-2012
Time (UTC)16:34
PlatformNot Applicable
File nameUpdate.mum
File versionNot Applicable
File size1,447
Date (UTC)17-Sep-2012
Time (UTC)12:46
PlatformNot Applicable

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Keywords: kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseadvanced, KB2727324

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Article Info
Article ID : 2727324
Revision : 4
Created on : 5/24/2013
Published on : 5/24/2013
Exists online : False
Views : 444