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Cannot Reuse a Campaign Item in the Campaign Manager


View products that this article applies to.

Symptoms

In Commerce Server, when you create a Campaign Item (Customer, Campaign, Ad, Direct Mail, or Discount) name in the Campaign Manager, the Campaign Item cannot be reused, even if it is deleted. If you attempt to create a new campaign with a deleted Campaign Item name, the following error message occurs:
Business Desk Error: Unable to Save the Customer/Campaign/Ad/Direct Mail/Discount
When you click the More Information button, you receive the following details:
ADO Error
Number: 0x0
Description:Campaign Item exists. Please type unique Campaign Item name
Source:Microsoft OLE DB Provider for SQL
SQL State:01000
Native Error:50000
-or-

Business Desk
Campaign Item exists. Please type a unique Campaign Item name.

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Cause

An entry with the Customer, Campaign, or Campaign Item name already exists in the Web site's Commerce database. By design, all Campaign Item data is reserved for analysis reporting. The dt_<customer/camp/campitem>_archived column in the Customer, Campaign, or Campaign_Item tables is used to hide campaign entries from BizDesk. You will either have to rename or unhide the Customer, Campaign, or Campaign Item.

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Workaround

Manually modify the Campaign_Item table for the Web site's SQL Server Commerce database.

NOTE: Analysis reports may be using the original entry in this table. Before you perform then following steps, verify that removal or recovery of this Campaign Item will not affect analysis information.
  1. Open the Microsoft SQL Server Enterprise Manager.
  2. When you have successfully gained access to SQL Server, expand the Commerce database that is related to your site.
  3. Select the Campaign table if you are attempting to recover a Campaign, select the Customer table if you are attempting to recover a customer, or select the Campaign_Item tables if you are attempting to recover either an Ad, Direct Mail, or Discount Campaign Item.
  4. Right-click the table, and then select Open Table - Return All Rows.
  5. If you want to recover the deleted Campaign Item, do the following:

    1. In the appropriate dt_< >_archieved column, locate the Campaign Item you want to recover (dt_customer_archieve - Customer table, dt_camp_archieved - Campaign table, and dt_campitem_archieved - Campaign_Item table).
    2. Highlight the contents of the cell, and then use the CTRL+0 (CTRL + Zero) key combination to enter a NULL value in the cell.

      NOTE: The value in this cell must be a NULL value. Pressing the space bar or entering <NULL> does not provide the necessary NULL content.
  6. If you want to reuse this Campaign Item, do the following:

    1. Locate the appropriate u_< >_name column for the campaign item you want to reuse (u_customer_name - Customer table, u_camp_name - Campaign table, and u_campitem_name - Campaign_Item table).
    2. At the end of the name, append OLD, 1, ARCH, or any character(s) to rename this item with a different name.
You can now open the BizDesk Campaign Manager and either re-use the desired Campaign Item name or see that the deleted Campaign Item has been recovered.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

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More information

kbsweptcomserv2002 mmushatt 16-Oct-2002

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Keywords: KB272708, kbpending, kbbug

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Article Info
Article ID : 272708
Revision : 4
Created on : 10/22/2003
Published on : 10/22/2003
Exists online : False
Views : 413