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Published Citrix application starts and then exits immediately on a Windows 2008 SP2-based Citrix server


View products that this article applies to.

Symptoms

When you start a published Citrix application on a Windows 2008 Service Pack 2 (SP2)-based Citrix server, the application starts and then exits immediately.

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Cause

This issue is caused by a timing issue in the TSJobCallback function. The timing issue causes the EnumProcessModules function in the TSJobCallback function to return a 0x5(ERROR_ACCESS_DENIED) error message. Therefore, an unexpected logoff occurs, and the Citrix application exits.

Note The TSJobCallback function is a callback function of the Winlogon process. The function is used to log off the user remote logon session after the processes that are started by the Userinit process end. The function uses the EnumProcessModules function to request the module information.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2008 Service Pack 2 (SP2). For more information about how to obtain a Windows Server 2008 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

968849 How to obtain the latest service pack for Windows Server 2008

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2008 file information notes
Important Windows Server 2008 hotfixes are included in the same packages. However, only "Windows Vista" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows Vista" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    VersionProductSR_LevelService branch
    6.0.600
    2.
    22xxx
    Windows Server 2008SP2LDR
  • Service Pack 1 is integrated into the release version of Windows Server 2008.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008" section. MUM files and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2008
File nameFile versionFile sizeDateTimePlatform
Winlogon.exe6.0.6002.22872407,55207-Jun-201214:01x64
Winlogon.exe6.0.6002.22872315,39207-Jun-201213:28x86
For all supported IA-64-based versions of Windows Server 2008
File nameFile versionFile sizeDateTimePlatform
Winlogon.exe6.0.6002.22872918,52807-Jun-201213:10IA-64
Winlogon.exe6.0.6002.22872315,39207-Jun-201213:28x86

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

For more information about the EnumProcessModules function, go to the following Microsoft website:

Additional file information

Additional file information for Windows Server 2008

Additional files for all supported x64-based versions of Windows Server 2008
File nameAmd64_75057ed988da6a34aa91c65343275e6b_31bf3856ad364e35_6.0.6002.22872_none_62115d921604751a.manifest
File versionNot applicable
File size1,040
Date (UTC)07-Jun-2012
Time (UTC)16:17
PlatformNot applicable
File nameAmd64_microsoft-windows-winlogon_31bf3856ad364e35_6.0.6002.22872_none_ce080f69a3c9bbe4.manifest
File versionNot applicable
File size21,160
Date (UTC)07-Jun-2012
Time (UTC)15:45
PlatformNot applicable
File nameX86_microsoft-windows-winlogon_31bf3856ad364e35_6.0.6002.22872_none_71e973e5eb6c4aae.manifest
File versionNot applicable
File size21,120
Date (UTC)07-Jun-2012
Time (UTC)15:00
PlatformNot applicable
Additional files for all supported IA-64-based versions of Windows Server 2008
File nameIa64_a46e2836929d7bafb1731766658e8ce3_31bf3856ad364e35_6.0.6002.22872_none_25c7718c3c445b23.manifest
File versionNot applicable
File size1,038
Date (UTC)07-Jun-2012
Time (UTC)16:17
PlatformNot applicable
File nameIa64_microsoft-windows-winlogon_31bf3856ad364e35_6.0.6002.22872_none_71eb17dbeb6a53aa.manifest
File versionNot applicable
File size21,140
Date (UTC)07-Jun-2012
Time (UTC)14:24
PlatformNot applicable
File nameX86_microsoft-windows-winlogon_31bf3856ad364e35_6.0.6002.22872_none_71e973e5eb6c4aae.manifest
File versionNot applicable
File size21,120
Date (UTC)07-Jun-2012
Time (UTC)15:00
PlatformNot applicable

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Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbexpertisebeginner, kbsurveynew

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Article Info
Article ID : 2721802
Revision : 1
Created on : 1/7/2017
Published on : 7/16/2012
Exists online : False
Views : 245