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Error message when you try to perform a remote wipe operation for a device in Exchange Server 2010: "The ActiveSyncDevice identity cannot be found"


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Symptoms

Consider the following scenario:
  • A user connects to a mailbox that is hosted on Microsoft Exchange Server 2010.
  • The user has a Microsoft Exchange ActiveSync partnership that works as expected.
  • You move the user to a new organizational unit (OU) or rename a user account in Active Directory Domain Services (AD DS).
  • You try to perform a remote wipe operation for the device in the Exchange Management Console (EMC).
In this scenario, you receive an error message that resembles the following when you try to perform a remote wipe operation for the device:
The ActiveSyncDevice identity cannot be found
Note In this error message, identity is the identity that is returned when you run the Get-ActiveSyncDeviceStatistics cmdlet together with the mailbox parameter.

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Cause

This issue occurs because the EMC does not use an up-to-date identity.

Notes
  • The EMC uses the identity that is returned when you run the Get-ActiveSyncDeviceStatistics cmdlet. This identity is not updated when a user is moved to a different OU or when the user account is renamed in AD DS.
  • To obtain the correct identity to use in a cmdlet, run the Get-ActiveSyncDevice cmdlet.

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Workaround

To work around this issue, use one of the following methods, as appropriate for your situation.

Method 1: Move the user to the OU where the device was first synchronized

To work around this issue, follow these steps:
  1. Temporarily move the user back to the OU where the device was first synchronized.
  2. Wipe the device.
  3. Move the user to the OU that you want.


Method 2: Rename the user account in AD DS

To work around this issue, follow these steps:
  1. Temporarily rename the account to the original name.
  2. Wipe the device.
  3. Rename the account again.


Method 3: Use the Clear-ActiveSyncDevice cmdlet

To work around this issue, run the Clear-ActiveSyncDevice cmdlet, and use the device distinguished name.

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More information

To re-provision the device, run the Remove-ActiveSyncDevice cmdlet, and use the device distinguished name. After you run the Remove-ActiveSyncDevice cmdlet, the correct identity is returned when you run the Get-ActiveSyncDeviceStatistics cmdlet. Additionally, the correct UserDisplayName value is returned when you run the Get-ActiveSyncDevice cmdlet.

Notes
  • The user mailbox is re-synchronized when you run the Remove-ActiveSyncDevice cmdlet.
  • After you run the Remove-ActiveSyncDevice cmdlet, you can correctly manage the device by using the EMC.

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References

For more information about the Get-ActiveSyncDeviceStatistics cmdlet, visit the following TechNet website:
For more information about the Clear-ActiveSyncDevice cmdlet, visit the following TechNet website:

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Keywords: KB2721428, kbtshoot, kbprb, kbsurveynew

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Article Info
Article ID : 2721428
Revision : 4
Created on : 9/21/2012
Published on : 9/21/2012
Exists online : False
Views : 291