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"The system cannot execute the specified program" error message and AppLocker incorrectly blocks applications on a Windows 7-based or Windows Server 2008 R2-based computer


View products that this article applies to.

Symptoms

Assume that you set some AppLocker rules to control which applications can run on a computer that is running Windows 7 or Windows Server 2008 R2. However, when you try to start applications that are not blocked by the AppLocker rules, AppLocker incorrectly prevents the applications from running and you receive the following error message:
The system cannot execute the specified program

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Cause

AppLocker maintains a cache to store the file attributes of the applications that are installed on a computer. AppLocker uses this cache to look up the file attributes quickly every time that you start an application, instead of computing those attributes again. When the cache reaches its maximum size, AppLocker removes entries from the cache to make room for new entries. Because of an issue in the way that AppLocker purges entries from the cache, the cache can sometimes become corrupted. In this situation, cache lookups start to fail. Therefore, AppLocker prevents applications from running, even though the AppLocker rules that are configured on the computer allow these applications.

The default size of the cache is large enough that most users will not experience this issue for a long time. Users who run lots of applications are more likely to experience this issue, because the cache reaches a size that triggers the purging logic.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running one of the following operating systems:
  • Windows 7
  • Windows 7 Service Pack 1 (SP1)
  • Windows Server 2008 R2
  • Windows Server 2008 R2 Service Pack 1 (SP1)
For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 7 and Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    VersionProductMilestoneService branch
    6.1.760
    0.21xxx
    Windows 7 and Windows Server 2008 R2RTMLDR
    6.1.760
    1.22xxx
    Windows 7 and Windows Server 2008 R2SP1LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows 7 and for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are critical to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
File nameFile versionFile sizeDateTimePlatform
Discache.sys6.1.7600.2123033,28009-Jun-201202:37x86
Discache.sys6.1.7601.2201533,28009-Jun-201202:28x86
For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Discache.sys6.1.7600.2123040,96009-Jun-201202:58x64
Discache.sys6.1.7601.2201540,96009-Jun-201202:54x64
For all supported IA-64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Discache.sys6.1.7600.2123093,18409-Jun-201202:18IA-64
Discache.sys6.1.7601.2201593,18409-Jun-201202:15IA-64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7
File nameX86_14af4431f7119bc9975d3649bc19f519_31bf3856ad364e35_6.1.7600.21230_none_e18b4398c5278956.manifest
File versionNot applicable
File size701
Date (UTC)09-Jun-2012
Time (UTC)09:08
PlatformNot applicable
File nameX86_e9a0a94078d9900448e055c1e12f9a57_31bf3856ad364e35_6.1.7601.22015_none_e25bbf5e3adb1f85.manifest
File versionNot applicable
File size701
Date (UTC)09-Jun-2012
Time (UTC)09:08
PlatformNot applicable
File nameX86_microsoft-windows-systemindexer_31bf3856ad364e35_6.1.7600.21230_none_d62cfdd09d75d3a8.manifest
File versionNot applicable
File size3,265
Date (UTC)09-Jun-2012
Time (UTC)05:08
PlatformNot applicable
File nameX86_microsoft-windows-systemindexer_31bf3856ad364e35_6.1.7601.22015_none_d82dfc209a878665.manifest
File versionNot applicable
File size3,265
Date (UTC)09-Jun-2012
Time (UTC)05:03
PlatformNot applicable
Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2
File nameAmd64_3901d5a739eebee27fdbb3624409e117_31bf3856ad364e35_6.1.7601.22015_none_124c70570159d9a7.manifest
File versionNot applicable
File size705
Date (UTC)09-Jun-2012
Time (UTC)09:08
PlatformNot applicable
File nameAmd64_e3790bc5118391b20a7264c9aaab5837_31bf3856ad364e35_6.1.7600.21230_none_2ef07aeb15a434de.manifest
File versionNot applicable
File size705
Date (UTC)09-Jun-2012
Time (UTC)09:08
PlatformNot applicable
File nameAmd64_microsoft-windows-systemindexer_31bf3856ad364e35_6.1.7600.21230_none_324b995455d344de.manifest
File versionNot applicable
File size3,269
Date (UTC)09-Jun-2012
Time (UTC)06:05
PlatformNot applicable
File nameAmd64_microsoft-windows-systemindexer_31bf3856ad364e35_6.1.7601.22015_none_344c97a452e4f79b.manifest
File versionNot applicable
File size3,269
Date (UTC)09-Jun-2012
Time (UTC)06:04
PlatformNot applicable
Additional files for all supported IA-64-based versions of Windows Server 2008 R2
File nameIa64_20955a3bf2a4ad8cf1a1a40ac21240f4_31bf3856ad364e35_6.1.7601.22015_none_ecf08088af9d4175.manifest
File versionNot applicable
File size703
Date (UTC)09-Jun-2012
Time (UTC)09:08
PlatformNot applicable
File nameIa64_90a3eff49736b803d7d321d6398ca496_31bf3856ad364e35_6.1.7600.21230_none_d4f7cdb64f77ae99.manifest
File versionNot applicable
File size703
Date (UTC)09-Jun-2012
Time (UTC)09:08
PlatformNot applicable
File nameIa64_microsoft-windows-systemindexer_31bf3856ad364e35_6.1.7600.21230_none_d62ea1c69d73dca4.manifest
File versionNot applicable
File size3,267
Date (UTC)09-Jun-2012
Time (UTC)05:53
PlatformNot applicable
File nameIa64_microsoft-windows-systemindexer_31bf3856ad364e35_6.1.7601.22015_none_d82fa0169a858f61.manifest
File versionNot applicable
File size3,267
Date (UTC)09-Jun-2012
Time (UTC)05:40
PlatformNot applicable

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Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbexpertisebeginner, kbsurveynew

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Article Info
Article ID : 2719305
Revision : 1
Created on : 1/7/2017
Published on : 7/19/2012
Exists online : False
Views : 141