Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Certificate is archived incorrectly when it enters the renewal period on a computer that is running Windows Server 2008 R2


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You install the Active Directory Certificate Services role on a computer that is running Windows Server 2008 R2 in a Windows Server 2008 R2-based domain environment.
  • The computer has some certificates that are enrolled from the same certificate template. The names of the certificates are different.  
  • You configure the auto-enrollment feature for the certificates and have the Renew expired certificates, update pending certificates, and remove revoked certificates option selected.
  • One of the certificates enters the renewal period. Then, the computer starts to perform the auto-enrollment process.
In this scenario, the certificate is archived incorrectly. Additionally, this issue causes a service outage. 

↑ Back to the top


Cause

This issue occurs because the certificate is archived incorrectly by the auto-enrollment feature. For example, assume that you have some certificates that are enrolled from the same offline template. The names of the certificates are different, and the renewal periods are defined by the template. When one of the certificates enters the renewal period, the auto-enrollment feature considers it as an expired certificate. Therefore, the certificate is archived incorrectly. If you do not configure auto-enrollment for the template, a new certificate cannot be generated. Therefore, the services that depend on the certificate fail.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2008 R2 or Windows Server 2008 R2 Service Pack 1 (SP1).

For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    VersionProductMilestoneService branch
    6.1.760
    0.16xxx
    Windows Server 2008 R2RTMGDR
    6.1.760
    1.22xxx
    Windows Server 2008 R2SP1LDR
  • GDR service branches contain only those fixes that are widely released to address widespread, critical issues. LDR service branches contain hotfixes in addition to widely released fixes.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Certenroll.dll6.1.7601.220831,979,39210-Aug-201204:37x64
Certenrollctrl.exe6.1.7600.1638570,14414-Jul-200901:38x64
Certenroll.dll6.1.7601.220831,335,29610-Aug-201204:29x86
Certenrollctrl.exe6.1.7601.2208367,07210-Aug-201204:28x86
For all supported IA-64-based versions of Windows Server 2008 R2
File nameFile versionFile sizeDateTimePlatform
Certenroll.dll6.1.7601.220833,855,36009-Aug-201218:00IA-64
Certenrollctrl.exe6.1.7600.16385112,12814-Jul-200901:44IA-64
Certenroll.dll6.1.7601.220831,335,29610-Aug-201204:29x86
Certenrollctrl.exe6.1.7601.2208367,07210-Aug-201204:28x86

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2
File nameAmd64_561794ebc1db71ab943f8ef114a7a60e_31bf3856ad364e35_6.1.7601.22083_none_ba6059a05a4fe008.manifest
File versionNot applicable
File size1,074
Date (UTC)10-Aug-2012
Time (UTC)09:34
PlatformNot applicable
File nameAmd64_microsoft-windows-x..rtificateenrollment_31bf3856ad364e35_6.1.7601.22083_none_51f98742be9ddf19.manifest
File versionNot applicable
File size368,541
Date (UTC)10-Aug-2012
Time (UTC)09:41
PlatformNot applicable
Additional files for all supported IA-64-based versions of Windows Server 2008 R2
File nameIa64_67a501f5743012c2be9debf5e7064eef_31bf3856ad364e35_6.1.7601.22083_none_d3c88ac72d8ce954.manifest
File versionNot applicable
File size1,072
Date (UTC)10-Aug-2012
Time (UTC)09:34
PlatformNot applicable
File nameIa64_microsoft-windows-x..rtificateenrollment_31bf3856ad364e35_6.1.7601.22083_none_f5dc8fb5063e76df.manifest
File versionNot applicable
File size368,539
Date (UTC)10-Aug-2012
Time (UTC)09:35
PlatformNot applicable

↑ Back to the top


Keywords: kb, kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseadvanced

↑ Back to the top

Article Info
Article ID : 2718646
Revision : 1
Created on : 1/7/2017
Published on : 1/11/2013
Exists online : False
Views : 211