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After planned System Maintenance, an error occurs when authenticating with Windows Live ID using a custom application in Microsoft Dynamics CRM 2011 Online: "The security token could not be authenticated or authorized."


Symptoms

After Microsoft Dynamics CRM Online Planned System Maintenance, custom applications accessing the Microsoft Dynamics CRM Online 2011 Windows Communication Foundation (WCF) endpoints may fail with the exception: 
ID3242: The security token could not be authenticated or authorized."

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Cause

The AppliesTo property used when authenticating to the Windows LiveId Services in the Organization.svc wsdl has been changed 

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Resolution

Change the AppliesTo constant in your application to the appropriate value as given in your wsdl. For example:

This applies to the Discovery, Organization, OrganizationData services:

https://dev.crm.dynamics.com/xrmservices/2011/discovery.svc?wsdl=wsdl1

https://.crm.dynamics.com/xrmservices/2011/organization.svc?wsdl=wsdl0

https://.crm.dynamics.com/xrmservices/2011/organizationdata.svc?wsdl=wsdl0

Look for the property:
<ms-xrm:AppliesTo>urn:crmna:dynamics.com</ms-xrm:AppliesTo>

In the past, this value was urn:crm:dynamics.com

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Keywords: kbmbspartner, kbmbsmigrate, kbsurveynew, kb

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Article Info
Article ID : 2717390
Revision : 1
Created on : 1/7/2017
Published on : 5/25/2012
Exists online : False
Views : 90