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FIX: Email message is not delivered when you create itinerary to dynamically route a message to an email address by using an LDAP query in BizTalk Server 2009 or 2010


View products that this article applies to.

Symptoms

Assume that you create an itinerary to dynamically route a message to an email address by using a Lightweight Directory Access Protocol (LDAP) query in Microsoft BizTalk Server 2009 or 2010. In this situation, the email message is not delivered, and you receive an error message that resembles the following:

There was a failure executing the receive pipeline:
"Microsoft.Practices.ESB.Itinerary.Pipelines.ItineraryReceiveXml, Microsoft.Practices.ESB.Itinerary.Pipelines, Version=2.1.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" Source: "ESB Dispatcher Disassemble" Receive Port: "OnRamp.Itinerary" URI: "/ESB.ItineraryServices/ProcessItinerary.asmx" Reason: Transport location could not be resolved from the resolver string

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Cause

This issue occurs because of an error in the LDAP resolver in BizTalk Server 2009.

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Resolution

For BizTalk Server 2010

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Cumulative update information

For BizTalk Server 2009

The fix that resolves this issue is included in cumulative update package 7 for BizTalk Server 2009.

For more information about how to obtain the cumulative update package, click the following article number to view the article in the Microsoft Knowledge Base:
2771015 Cumulative update package 7 for BizTalk Server 2009

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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References

For more information about how to create an itinerary to dynamically route a message to an email address by using an LDAP query, go to the following MSDN website: For information about the service packs and cumulative update list for BizTalk Server, click the following article number to view the article in the Microsoft Knowledge Base:
2555976 Service pack and cumulative update list for BizTalk Server
For more information about BizTalk Server hotfixes, click the following article number to view the article in the Microsoft Knowledge Base:
2003907 Information about BizTalk hotfixes and service pack support

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Keywords: kbqfe, kbfix, kbsurveynew, kbexpertiseadvanced, kbhotfixserver, kbautohotfix, kb

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Article Info
Article ID : 2714922
Revision : 1
Created on : 1/7/2017
Published on : 5/18/2015
Exists online : False
Views : 387