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Microsoft Dynamics CRM for Microsoft Office Outlook configuration fails with error: "There is a problem communicating with the Microsoft Dynamics CRM server. The server might be unavailable. If the problem persists, contact your system administrator"


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Symptoms

When attempting to configure the Microsoft Dynamics CRM for Microsoft Office Outlook, a user receives the following error during the "Initializing Organization" phase of the configuration process:

"There is a problem communicating with the Microsoft Dynamics CRM server. The server might be unavailable. If the problem persists, contact your system administrator"

or

“Cannot configure the organization for Microsoft Dynamics CRM for Outlook. Try to configure the organization again. If the problem persists, contact your system administrator”

When you click Details, the following additional details are shown:

"An item with the same key has already been added.    at Microsoft.Crm.Application.Outlook.Config.OutlookConfigurator.InitializeMapiStoreForFirstTime()
   at Microsoft.Crm.Application.Outlook.Config.OutlookConfigurator.Configure(IProgressEventHandler progressEventHandler)
   at Microsoft.Crm.Application.Outlook.Config.ConfigEngine.Configure(Object stateInfo)"


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Cause

This issue is caused by duplicate site-map entries in the site-map XML relative to the <SubArea Id> tag. A duplicate site-map entry will sometimes contain a trailing "(1)" at the end of the title, as seen in the screenshot below:

Accounts(1)


However, it also possible to experience this error without seeing a duplicated entity name in the web client UI. Instead, the issue may also occur where the <SubArea Id> tag references the same name, while the Entity parameter is different, as highlighted below:

<SubArea Id="new_entity" Entity="new_entity"/>

<SubArea Id="new_entity" Entity="new_otherentity"/>

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Resolution


1. In Microsoft Dynamics CRM, click Settings, and then click Solutions.

2. Click New. Enter an appropriate Display Name, Name, Publisher, and Version. Click Save.

3. Click Add Existing and select Site Map.

4. Click Save and then click Export Solution.

5. Follow the Export Solution dialog box and ensure the solution is exported as Unmanaged.

6. Once the solution is exported, unzip the contents of the solution file.

7. In the unzipped folder, right-click customizations.xml, select Open With, and click Notepad.

8. Based on where the duplicate entry is located in the web client UI, locate and remove the duplicate site-map entry. For example, if the duplicate site-map entry was "Accounts(1)", and this appeared in the Sales pane, the duplicate entry would appear as below:

<Area Id="SFA" ResourceId="Area_Sales" Icon="/_imgs/sales_24x24.gif" DescriptionResourceId="Sales_Description">
        <Group Id="SFA">
          <SubArea Id="nav_leads" Entity="lead" DescriptionResourceId="Lead_SubArea_Description" GetStartedPanePath="Leads_Web_User_Visor.html" GetStartedPanePathAdmin="Leads_Web_Admin_Visor.html" GetStartedPanePathOutlook="Leads_Outlook_User_Visor.html" GetStartedPanePathAdminOutlook="Leads_Outlook_Admin_Visor.html" />
          <SubArea Id="nav_oppts" Entity="opportunity" DescriptionResourceId="Opportunity_SubArea_Description" GetStartedPanePath="Opportunities_Web_User_Visor.html" GetStartedPanePathAdmin="Opportunities_Web_Admin_Visor.html" GetStartedPanePathOutlook="Opportunities_Outlook_User_Visor.html" GetStartedPanePathAdminOutlook="Opportunities_Outlook_Admin_Visor.html" />
<SubArea Id="nav_accts" Entity="account" DescriptionResourceId="Account_SubArea_Description" GetStartedPanePath="Accounts_Web_User_Visor.html" GetStartedPanePathAdmin="Accounts_Web_Admin_Visor.html" GetStartedPanePathOutlook="Accounts_Outlook_User_Visor.html" GetStartedPanePathAdminOutlook="Accounts_Outlook_Admin_Visor.html" />
<SubArea Id="nav_accts" Entity="account" DescriptionResourceId="Account_SubArea_Description" GetStartedPanePath="Accounts_Web_User_Visor.html" GetStartedPanePathAdmin="Accounts_Web_Admin_Visor.html" GetStartedPanePathOutlook="Accounts_Outlook_User_Visor.html" GetStartedPanePathAdminOutlook="Accounts_Outlook_Admin_Visor.html" />

As seen above, the Area ResourceId is "Area_Sales", while the original and duplicate Site Map entry for "Accounts" is listed in the bolded SubArea Id tags. 

9. With the duplicate entry removed, save the customizations.xml file.

10. Re-package the customizations.xml, [Content_Types].xml, and solution.xml into a new zipped file. Select these files, right-click, select Send To, and click "Compressed zipped folder".

11. In Microsoft Dynamics CRM, click Settings, and then click Solutions.

12. Click Import.

13. Select the modified site map solution zip file, click Next.

14. Click Next on the Import Solution dialog box. Click Publish All Customizations. Click Close.


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More Information

If you are still encountering issues connecting CRM for Outlook to your CRM Online organization, a diagnostic tool is available to help diagnose the issue:

CRM for Outlook Configuration Diagnostic

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Keywords: kbmbspartner, kbmbsmigrate, kbsurveynew, kb

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Article Info
Article ID : 2714083
Revision : 1
Created on : 1/7/2017
Published on : 2/4/2016
Exists online : False
Views : 311