Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

System Attendant generates Event ID 9186 and Event ID 9187 in Exchange 2000 and in Exchange 2003


View products that this article applies to.

This article was previously published under Q271335

↑ Back to the top


Symptoms

After you move a Microsoft Exchange 2000 Server computer or a Microsoft Exchange Server 2003 computer from one organizational unit to another within the domain, or after you rename the organizational unit, the following events are logged in the application event log:
Event ID: 9186
Source: MSExchangeSA
Type: Warning
Category: General
Description:
Microsoft Exchange System Attendant has detected that the local computer is not a member of group 'cn=Exchange Domain Servers,cn=Users,dc=microsoft,dc=com'. System Attendant is going to add the local computer into the group.
The current members of the group are 'CN=SERVERNAME,OU=NEWOU,DC=microsoft,DC=com; '.
-and-
Event ID: 9187
Source: MSExchangeSA
Type: Error
Category: General
Description:
Microsoft Exchange System Attendant failed to add the local computer as a member of the DS group object 'cn=Exchange Domain Servers,cn=Users,dc=microsoft,dc=com'.
Please stop all the Microsoft Exchange services, add the local computer into the group manually and restart all the services.
These events are logged even though the Exchange Server computer is a member of the Exchange Domain Servers group.

↑ Back to the top


Cause

This issue may occur if the following condition is true:
  • The Exchange Server computer's distinguished name has been changed. When System Attendant starts, it caches the distinguished name of the local computer. The Exchange Server computer's distinguished name changes when it is moved from one organizational unit to another organizational unit. The new distinguished name is different from the distinguished name that is in the cache. Therefore, System Attendant logs event ID 9186 and 9187 messages.

↑ Back to the top


Resolution

To resolve this issue, use the appropriate method.

Method 1

Restart System Attendant to refresh the cached value.

Note You must restart the following services that depend on the System Attendant service:
  • Microsoft Exchange Information Store
  • Microsoft Exchange Message Transfer Agent (MTA) Stacks
  • Microsoft Exchange Event
  • Microsoft Exchange Internet Message Access Protocol, Version 4rev1 (IMAP4)
  • Microsoft Exchange Post Office Protocol version 3 (POP3)

Method 2

If your Exchange Server computer is not listed, follow these steps:
  1. Remove the Exchange Server computer account from the Exchange Domain Servers group.
  2. Add the Exchange Server computer account back.
  3. Restart System Attendant.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

The machine account for the Exchange Server computer can be moved to an organizational unit other than Computers in Microsoft Active Directory directory service without any problems.

↑ Back to the top


Keywords: KB271335, kbsysadmin, kbprb, kbnofix, kberrmsg, kbbug

↑ Back to the top

Article Info
Article ID : 271335
Revision : 12
Created on : 10/25/2007
Published on : 10/25/2007
Exists online : False
Views : 260