Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

FIX: MSBuild rebuilds unchanged IDL files when you use the Visual Studio x64 Win64 Command Prompt in Visual Studio 2010


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You run the Visual Studio x64 Win64 Command Prompt in Microsoft Visual Studio 2010. 
  • At the command prompt, you use the Microsoft Build Engine (MSBuild) to build a Visual C++ project that contains IDL files. For example, you build an Active Template Library (ATL) project that is named MyATLProject.

    Note To do this, type the following command at the command prompt, and then press Enter:

    msbuild MyATLProject.vcxproj
  • You build the project again.
In this scenario, MSBuild rebuilds the IDL files even through the IDL files are unchanged.

Notes
  • This issue typically occurs when the following Microsoft security updates are installed on the computer:

    2507938 MS11-056: Vulnerabilities in Windows CSRSS could allow elevation of privilege: July 12, 2011
    2567680 MS11-063: Vulnerability in Windows Client/Server Run-time subsystem could allow elevation of privilege: August 9, 2011
  • We do not recommend that you remove any security updates. 

↑ Back to the top


Cause

This issue occurs because of a bug in the 64-bit version of Tracker.exe.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is now available from Microsoft. However, it is intended to correct only the problem that is described in this article. Apply it only to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

To resolve this problem immediately, contact Microsoft Customer Support Services to obtain the hotfix. For a complete list of Microsoft Customer Support Services telephone numbers and information about support costs, visit the following Microsoft website:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

To apply this hotfix, you must have Visual Studio 2010 Service Pack 1 (SP1) installed.

Restart requirement

You do not have to restart the computer after you apply this hotfix if the affected files are not being used. We recommend that you close all Microsoft Visual Studio 2010-related components before you install the hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

For all supported x86-based versions of Windows
File nameFile versionFile sizeDateTimePlatform
Filetracker.dll10.0.30319.571174,16003-Jul-201204:15x86
For all supported x64-based versions of Windows
File nameFile versionFile sizeDateTimePlatform
Filetracker.dll10.0.30319.571174,16003-Jul-201204:15x86
Filetracker.dll10.0.30319.571221,77603-Jul-201204:41x64

↑ Back to the top


Workaround

To work around this issue, use the one of the following Visual Studio 2010 tools to compile the IDL file:
  • Visual Studio Command Prompt
  • Visual Studio x64 Cross Tools Command Prompt
  • Visual Studio Itanium Cross Tools Command Prompt

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


Keywords: kbqfe, kbhotfixserver, kbfix, kbsurveynew, kbexpertiseadvanced, kbhotfixdev, kb

↑ Back to the top

Article Info
Article ID : 2711617
Revision : 1
Created on : 1/7/2017
Published on : 8/10/2012
Exists online : False
Views : 309