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Error message when you try to receive a purchase order in Microsoft Dynamics GP: "One or more purchase order items can't be received as they have an encumbrance status of pre-encumbered or invalid"


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Symptoms

When you try to receive a shipment or a shipment/invoice document against a purchase order in the Receivings Transaction Entry window, you receive the following error message: 
One or more purchase order items can't be received as they have an encumbrance status of pre-encumbered or invalid.

Note Encumbrance Management is enabled and all Purchase Order Documents that receive this error come from Business Portal Requisition Management.

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Cause

No integration has ever existed between Business Portal Requisition Management and Encumbrance Management and new columns were added to the POP10100 table that now render previous steps to get by the issue obsolete.

In versions prior to Microsoft Dynamics GP 10.0 RTM, users would not receive the error and could get by the missing integration by encumbering the Purchase Order documents that came from Business Portal Requisition Management in either the Mass Encumbrance window or by running Encumbrance Routine Maintenance. Even though they were able to complete the receiving process there were no checks against the budget using these steps. The Mass Encumbrance window and Encumbrance Routine Maintenance would populate the Encumbrance Management tables for the Purchase Order documents so that processing against the purchase order could continue.

In Microsoft Dynamics GP 10.0 RTM and later versions, new columns have been added to the POP10100 table. Due to the addition of these columns these steps no longer allow users to continue the receiving process. When you use either the Mass Encumbrance window or the Encumbrance Routine Maintenance window to encumber the Purchase Orders, the system will encumber the Purchase Order documents allowing you to move forward with printing. However when you try to enter a shipment receipt the following error message: 
One or more purchase order items can't be received as they have an encumbrance status of pre-encumbered or invalid

In Microsoft Dynamics GP 10.0 RTM and later versions, new columns exist in the POP10100 table for the additional workflow functionality. Those columns are Workflow_Approval_Status and Workflow_Priority. These columns have a default value of 0 when Purchase Order documents are brought in from Requisition Management. The default values for a purchase order created through the Purchase Order Entry window are 9 and 2 respectively. The Requisition Management default values of 0 are not valid and this results in Encumbrance Management being unable to handle the transaction correctly.

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Resolution

Do not use Encumbrance Management when creating Purchase Order documents via Business Portal Requisition Management. It is not supported and tables do not populate correctly, which results in an error when attempting to receive against the Purchase Order documents. Customers that are using BP Requisition Management and Encumbrance Management in Microsoft Dynamics GP 10.0 RTM and later versions will receive the error reported in this article. There is no workaround for this issue, however, you can get past the error referenced in this article by performing one of the following:

  • Manually update the tables via SQL to show the Workflow_Approval_Status field as a value of 9 and the Workflow_Priority field as a value of 2 in the POP10100.
  • If manual updates are not suitable for your business you can look at creating a SQL trigger to automatically populate the data for you. If assistance is needed in creating this type of trigger please contact support and we can forward your request to Professional Services for a quote. This type of service is considered consulting and there would be a charge for creating a SQL trigger. If you want to pursue this option, contact Customer Service. To do this, telephone 888-477-7877, or visit the following Microsoft Web site:

    https://mbs.microsoft.com/support/newstart.aspx
Note In cases where you print the Purchase Order document after the document is created via Requisition Management and prior to updating the Workflow_Approval_Status and Workflow_Priority fields, the status of the Purchase Orders are populated with the wrong status of Pre-budget. When you try to receive, you receive the following error message:
One or more purchase order items can't be received as they have an encumbrance status of pre-encumbered or invalid

In addition, when you look at the purchase order in the Mass encumbrance window, it displays as Pre-budget. If you encounter this situation, in addition to updating the values mentioned above, you will need to also update the ENCBSTAT field in the ENC10110 table for the purchase order to 2 (pre-encumbrance). Use the Mass Encumbrance window to Encumber and then reprint the Purchase Order. 

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Keywords: kbmbspartner, kbmbsmigrate, kbsurveynew, kb

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Article Info
Article ID : 2709819
Revision : 1
Created on : 1/7/2017
Published on : 5/17/2012
Exists online : False
Views : 172